Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000953 [Resin] minor always 02-20-06 11:48 03-02-06 16:26
Reporter ferg View Status public  
Assigned To
Priority urgent Resolution fixed  
Status closed   Product Version
Summary 0000953: access.log rollover bug
Description (rep by Olaf Jentsch)

We have used Resin-pro-3.0.15 for months an the rollover of access.log
took place every midnight receiving the first request at the new day.

We are using this option: rollover-period="1D"

But with Resin-pro-3.0.17 we have the same problem as with 3.0.8.
The rollover takes place but instead of starting with a new empty file it
contains all the entries from the old day and adds the new ones so
constantly increasing the file size.

I think it is the old bug from 3.0.8, which was definitely fixed in
3.0.14, but maybe the fix was introduced in an earlier version, that we
did'nt use.

Additional Information
Attached Files

- Relationships

- Notes
(0000943)
ferg
03-24-06 09:24

My hack to check the log file name bugged me, so I've changed the workaround to the com.caucho.vfs.AbstractRolloverLog class. It's still a hack since the real fix would be closing the file handle, which I haven't been able to find without a complete audit of the log file instances.
 
The hack is in the movePathToArchive method. Similar to the previous one: empty access log file content if can't delete.
    boolean removed = path.remove();
    if (!removed && this instanceof AccessLogWriter && path instanceof FilePath
        && ((FilePath)path).getFile().exists()) {
        // open file in non-append mode and close it
        new FileOutputStream(((FilePath)path).getFile(), false).close();
    }
My concern is that a hack at the vfs level could break something in Resin that I'm not aware of. So far it seems to be working.
 

- Issue History
Date Modified Username Field Change
02-20-06 11:48 ferg New Issue
03-23-06 16:27 ferg Priority normal => urgent
03-24-06 09:24 ferg Note Added: 0000943
03-02-06 16:26 ferg Status new => closed
03-02-06 16:26 ferg Resolution open => fixed
03-02-06 16:26 ferg Fixed in Version  => 3.0.19


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
28 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker