Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000664 [Resin] minor always 01-03-06 10:03 01-02-06 16:49
Reporter ferg View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.0.17
Summary 0000664: file/directory expanded deployments
Description 5 -- file/directory expanded deployments

there currently exists in the default Resin distribution:
    resin/deploy/ [for .ear files]
    resin/webapps/ [for .war files]

.ear files contain modules of types .war, .rar, and .jar (EJB interfaces and implementations)

For example:

    myapplication.ear/
      myweb1.war/
      myweb2.war/
      myejb.jar/
      myservices.rar/

It is preferable to work with all of the above in an expanded state __but
with the same name as the .jar files__ for in-place deployment -- do not
create _ear_myapp, _war_myweb, _rar_myresource directories, because this
allows classloaders which look inside jars for resources to work in both
the development and production deployment "modes".


if path is a directory
  if filename does not have an extension
    check for directory/META-INF[resin-]/application.xml -> expanded .ear
    check for directory/META-INF/[resin-]ra.xml -> expanded .rar
    check for directory/WEB-INF/[resin-]web.xml -> expanded .war
    check for directory/META-INF/MANIFEST.MF -> expanded .jar

  if filename ends in .ear
    check for directory/META-INF[resin-]/application.xml -> expanded .ear

  if filename ends in .rar
    check for directory/META-INF/[resin-]ra.xml -> expanded .rar

  if filename ends in .war
    check for directory/WEB-INF/[resin-]web.xml -> expanded .war

  if filename ends in .jar
    check for directory/META-INF/MANIFEST.MF -> expanded .jar



Objective:

to be able to edit any source file within the above directories and have
automatic recompilation and class reloading take place.

Hope that this has been useful. Thank you for your time and consideration.
Additional Information
Attached Files

- Relationships

- Notes
(0000824)
ferg
01-02-06 16:49

server/10to
 

- Issue History
Date Modified Username Field Change
01-03-06 10:03 ferg New Issue
01-02-06 16:49 ferg Note Added: 0000824
01-02-06 16:49 ferg View Status @0@ => public
01-02-06 16:49 ferg Description Updated
01-02-06 16:49 ferg Assigned To  => ferg
01-02-06 16:49 ferg Status new => closed
01-02-06 16:49 ferg Resolution open => fixed
01-02-06 16:49 ferg Fixed in Version  => 3.0.18


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker