Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005055 [Resin] minor always 04-02-12 09:41 05-09-12 17:04
Reporter cowan View Status public  
Assigned To cowan
Priority high Resolution fixed  
Status closed   Product Version 3.1.12
Summary 0005055: Slow response with save-mode=after-request
Description When using session-config save-mode=after-request, responses to the client are delayed by the time it takes to serialize, CRC, and persist the session. The description of after-request says "Save the session after the request has been served and completed". This is true, however the response is stored in the buffer but not flushed to the client unit the request is "finished".

The response needs to be flushed before the session is persisted.
Additional Information Reported by IHG
Attached Files

- Relationships

- Notes
(0005756)
cowan
05-06-12 12:00
edited on: 05-06-12 12:02

Response is delayed only using load-balance. HmuxLoadBalancerServlet waits for the HMUX_QUIT signal before flushing the response to the client, which HmuxRequest does not deliver until after the invocation is complete. HttpRequest does not suffer from this, thus connections direct to the app-tier are faster for the 1st request.

Additionally, all requests of a keep-alive sequence except the 1st are delayed for session persistence. Even though the session is persisted after the response is written, the connection thread is busy persisting the session and not available to process the next incoming request.

load-balance-connect-timeout and load-balance-socket-timeout are significant here, because if the pier app-server is unresponsive or slow, the delay can be significant.

 
(0005760)
cowan
05-09-12 17:04

server/015p
 

- Issue History
Date Modified Username Field Change
04-02-12 09:41 cowan New Issue
05-06-12 12:00 cowan Note Added: 0005756
05-06-12 12:01 cowan Note Edited: 0005756
05-06-12 12:02 cowan Note Edited: 0005756
05-06-12 12:04 cowan Status new => assigned
05-06-12 12:04 cowan Assigned To  => cowan
05-09-12 17:04 cowan Status assigned => closed
05-09-12 17:04 cowan Note Added: 0005760
05-09-12 17:04 cowan Resolution open => fixed
05-09-12 17:04 cowan Fixed in Version  => 3.1.13


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
32 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker