Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005010 [Resin] major sometimes 04-02-12 05:03 06-11-12 15:42
Reporter mate View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 4.0.27
Summary 0005010: BaseTypeFactory may cause classloader leaks
Description Looks like another possible classloader leak in Resin, that will come into play if the LRU cache is not turned around fast enough.
Additional Information Supposedly, those caches should be cleared at application redeploy.
Attached Files  resin4027.png [^] (54,268 bytes) 04-02-12 05:03
 resin4027b.png [^] (68,999 bytes) 04-02-12 05:19
 resin4027_repeat.png [^] (54,268 bytes) 05-01-12 22:00
 resin4027b_repeat.png [^] (68,999 bytes) 05-01-12 22:00

- Relationships

- Notes
(0005727)
mate
04-02-12 05:19

May have been a bit quick there. Looks more likely that the com.caucho.config.inject.InjectManager should be disposed when application is redeployed, but that does not seem to work as expected.
 
(0005731)
mate
04-03-12 07:58

It does seem, that the problem is that InjectManagers higher up in the hierarchy ("host:default", "resin-system:" and even "") keeps classes of our web app in their _beanMap (and potentially BaseTypeFactory LRU cache).

Don't know if it is relevant, that in our particular case, it is the backing bean of the JSF error page, declared in web.xml <error-page>
 
(0005823)
ferg
06-11-12 15:42

The primary issue looks like an internal class creation of the AnnotationLiteral that's capturing the current context, but being saved in a global context.
 

- Issue History
Date Modified Username Field Change
04-02-12 05:03 mate New Issue
04-02-12 05:03 mate File Added: resin4027.png
04-02-12 05:16 mate Issue Monitored: mate
04-02-12 05:19 mate Note Added: 0005727
04-02-12 05:19 mate File Added: resin4027b.png
04-03-12 07:58 mate Note Added: 0005731
05-01-12 22:00 mate File Added: resin4027_repeat.png
05-01-12 22:00 mate Issue End Monitor: mate
05-01-12 22:00 mate Issue Monitored: mate
05-01-12 22:00 mate File Added: resin4027b_repeat.png
06-11-12 15:42 ferg Note Added: 0005823
06-11-12 15:42 ferg Assigned To  => ferg
06-11-12 15:42 ferg Status new => closed
06-11-12 15:42 ferg Resolution open => fixed
06-11-12 15:42 ferg Fixed in Version  => 4.0.28


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
40 total queries executed.
28 unique queries executed.
Powered by Mantis Bugtracker