Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004478 [Quercus] major always 04-05-11 11:07 04-13-11 07:00
Reporter chiefgeek View Status public  
Assigned To
Priority normal Resolution open  
Status new   Product Version 4.0.7
Summary 0004478: wordpress 3.1 and 3.1.1 default install - administrator does not have rights to edit posts /wp-admin/
Description The edit option is gone from wp-admin on wordpress 3.1 and 3.1.1.
Additional Information If you view the post and have the admin tool bar enabled while viewing the post, the edit post is enabled (for some posts, not all).
Attached Files

- Relationships

- Notes
04-05-11 20:38

This sounds like a problem I encountered. Do you mean that in the admin dashboard, in the table list view of posts, you don't see Edit links? I had to modify /wp-includes/post.php. In the "get_post_types" function just above the return statement, I added:

  // Without this line, $wp_post_types gets mangled.
  // Why? Good question - I don't know.
  if (count($args) == 0) $args[0] = null;

However I was using Resin 4.0.16 so this may be unrelated.
04-06-11 04:03

Yes I am talking about the edit links on the admin page (only link available is view).

I tried resin 4.0.16 with same results.

If I downgrade wordpress to 3.0.5 the edit links re-appear.

The fix suggested by mhixson worked.
04-06-11 13:45

Actually, I've since changed that line to:

  if (count($args) == 0) $args["show_ui"] = true;

Without that, the Pages screen in the admin dashboard shows Posts instead of Pages.
04-13-11 07:00
edited on: 04-13-11 07:01

This make the edit option re-appear for me. :)

If I enable the "All in one SEO plugin" I get "Invalid post_type" any time I try to view posts in the admin tool.


- Issue History
Date Modified Username Field Change
04-05-11 11:07 chiefgeek New Issue
04-05-11 20:38 mhixson Note Added: 0005159
04-06-11 04:03 chiefgeek Note Added: 0005160
04-06-11 13:45 mhixson Note Added: 0005167
04-13-11 07:00 chiefgeek Note Added: 0005193
04-13-11 07:01 chiefgeek Note Edited: 0005193
04-13-11 09:09 kdecherf Issue Monitored: kdecherf

Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
38 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker