Mantis - Quercus
Viewing Issue Advanced Details
4478 major always 04-05-11 11:07 04-13-11 07:00
new 4.0.7  
0004478: wordpress 3.1 and 3.1.1 default install - administrator does not have rights to edit posts /wp-admin/
The edit option is gone from wp-admin on wordpress 3.1 and 3.1.1.
If you view the post and have the admin tool bar enabled while viewing the post, the edit post is enabled (for some posts, not all).

04-05-11 20:38   
This sounds like a problem I encountered. Do you mean that in the admin dashboard, in the table list view of posts, you don't see Edit links? I had to modify /wp-includes/post.php. In the "get_post_types" function just above the return statement, I added:

  // Without this line, $wp_post_types gets mangled.
  // Why? Good question - I don't know.
  if (count($args) == 0) $args[0] = null;

However I was using Resin 4.0.16 so this may be unrelated.
04-06-11 04:03   
Yes I am talking about the edit links on the admin page (only link available is view).

I tried resin 4.0.16 with same results.

If I downgrade wordpress to 3.0.5 the edit links re-appear.

The fix suggested by mhixson worked.
04-06-11 13:45   
Actually, I've since changed that line to:

  if (count($args) == 0) $args["show_ui"] = true;

Without that, the Pages screen in the admin dashboard shows Posts instead of Pages.
04-13-11 07:00   
This make the edit option re-appear for me. :)

If I enable the "All in one SEO plugin" I get "Invalid post_type" any time I try to view posts in the admin tool.