Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003853 [Resin] minor always 01-19-10 09:23 03-03-10 12:28
Reporter alex View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 4.0.3
Summary 0003853: timestamp in logging seem to jump between local and UTC
Description rep by: Jamison Novak
I keep forgetting to report this, but it looks like something is wonky with log timestamps in 4.0.3 (and may go back further in 4.0; I can't remember). Here's an example of the time jumping back and forth between our local time (CST) and what I assume is UTC:
 
[2010/01/19 00:55:59.871] INFO in com.mltvacations.delta.data.ResetManager: [sid:] [rid:] [pid:] Running the ResetManager.
[2010/01/19 06:58:03.374] INFO in com.mltvacations.delta.data.ResetManager: [sid:] [rid:] [pid:] Running the ResetManager.
[2010/01/19 06:58:06.511] INFO in com.mltvacations.delta.data.ResetManager: [sid:] [rid:] [pid:] Running the ResetManager.
[2010/01/19 00:58:21.156] INFO in com.mltvacations.delta.data.ResetManager: [sid:] [rid:] [pid:] Running the ResetManager.
[2010/01/19 00:58:29.607] INFO in com.mltvacations.delta.data.ResetManager: [sid:] [rid:] [pid:] Running the ResetManager.
 
For reference, this is in one of our instances's stdout.log and continues throughout the log . It does not appear to happen in the other logs (jvm, gc).
 
In case it's of interest to narrow it down, here's how we specify our logs in resin.xml:
 
  <log-handler name="" level="info" path="stdout:"
       timestamp="[%Y/%m/%d %H:%M:%S.%s]"
       format="${log.level} in ${log.name} ${log.message} ${log.thrown}"/>
 
  <logger name="com.caucho" level="info"/>
  <logger name="com.caucho.java" level="config"/>
  <logger name="com.caucho.loader" level="config"/>
 
Under host-default (since ${cluster.id} is missing):
 
   <host-default>
     <stdout-log path="${resin.root}/log/${server.id}-stdout.log"
       archive-format="${server.id}-stdout.log.%Y%m%d.gz"
       rollover-period="1D" rollover-count="14"/>
   </host-default>
 
Let me know if you need anything else, or if you think this is a configuration issue and want me to change something on my end and verify.
 
Thanks!
Additional Information
Attached Files

- Relationships

- Notes
(0004440)
ferg
02-18-10 11:53

Thanks. That should be enough information. Looking at the code, though, I don't see yet why there would be a switch. The calendar is unique to the formatting and doesn't switch time zones (in other words, it's not shared with a different calendar for a non-local time.)
 

- Issue History
Date Modified Username Field Change
01-19-10 09:23 alex New Issue
02-18-10 11:53 ferg Note Added: 0004440
03-03-10 12:28 ferg Assigned To  => ferg
03-03-10 12:28 ferg Status new => closed
03-03-10 12:28 ferg Resolution open => fixed
03-03-10 12:28 ferg Fixed in Version  => 4.0.6


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker