Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002862 [Resin] minor always 08-25-08 09:06 08-03-09 14:41
Reporter posenato View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.1.6
Summary 0002862: Apache + Resin and 503 HTTP Error
Description We have a Resin + Apache 2.2.3 system that manages some virtual web sites.

Since the load is increasing, we have updated the h/w and the Resin version.

Now it is 3.1.6.

Since the update, we have noted an increasing of the 503 httpd error. The server load is near to 0!!

We have tried to tune the timeout & keepalive parameters, but the documentation is conflicting.
The page http://www.caucho.com/resin/doc/tuning.xtp [^] has some wrong parameter names and value.

Is there any place where the relation between load-balance-idle-time and socket-timeout and keepalive-timeout is made clear?

I have read in post 0002715 that there is another parameter to set up (<load-balance-socket-timeout>), but I have no found any documentation about it and how to relate its value w.r.t. the others parameter!
Additional Information
Attached Files

- Relationships

- Notes
(0003375)
Aatos
09-03-08 02:42

We're having the same problem on RHEL3 with Apache 2.2.8/Resin 3.1.6 loadbalanced with mod_caucho.

We get random 503 responses which do not correlate on the load state of Apache server or Resin nodes, tweaking settings seems to have no effect.
 
(0003523)
smallufo
10-01-08 16:51
edited on: 10-01-08 16:52

I have the same situation.
In resin 3.0.x , it never occurred.
After upgrading to 3.1.6 , it happens so often.
The load is very low....

servers :

linux 2.6.9-67.0.22.ELsmp (64 bit)
CentOS release 4.7 (Final)
httpd-2.0.52-41.ent.centos4


linux 2.6.18-92.1.6.el5 (32 bit)
CentOS release 5.2 (Final)
httpd-2.2.3-11.el5_1.centos.3

 
(0003525)
smallufo
10-03-08 00:52

I think the Severity should be MAJOR
 
(0004024)
stone_111
05-15-09 05:22

Any updates?

See this problem in 3.1.8, Apache 2, SUSE, singleserver.

Is there some unknown relation between apache and resin via mod_caucho that isn't properly documented?
 
(0004030)
stone_111
05-25-09 00:48

This seems to be an issue when upgrading from older Resin versions and using a newer Apache as well. A <socket-timeout>180s</socket-timeout> under <server> seems to have remedied the problem. Seems communication between apache and resin has been changed somehow or a default value has been changed. Documentation is a bit sparse and contradicting, but we see no 503:s at all now.
 
(0004206)
ferg
08-03-09 14:41

server/26e2

The important configuration are load-balance-socket-timeout, socket-timeout, load-balance-idle-time and keepalive-timeout. The two load-balance-* configure mod_caucho. socket-timeout and keepalive-timeout configure the Resin side.

load-balance-socket-timeout needs to be large enough to handle any server-side processing delays before the first data.

socket-timeout and keepalive-timeout need to be larger than load-balance-idle-time because they need to keep the connection open for a keepalive request.

For a diagram, see

  http://caucho.com/resin/admin/load-balancing.xtp [^]
 

- Issue History
Date Modified Username Field Change
08-25-08 09:06 posenato New Issue
09-03-08 02:42 Aatos Note Added: 0003375
09-03-08 02:42 Aatos Issue Monitored: Aatos
10-01-08 16:51 smallufo Note Added: 0003523
10-01-08 16:52 smallufo Note Edited: 0003523
10-03-08 00:48 smallufo Issue Monitored: smallufo
10-03-08 00:52 smallufo Note Added: 0003525
05-15-09 05:22 stone_111 Note Added: 0004024
05-25-09 00:48 stone_111 Note Added: 0004030
08-03-09 14:41 ferg Note Added: 0004206
08-03-09 14:41 ferg Assigned To  => ferg
08-03-09 14:41 ferg Status new => closed
08-03-09 14:41 ferg Resolution open => fixed
08-03-09 14:41 ferg Fixed in Version  => 4.0.2


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
46 total queries executed.
35 unique queries executed.
Powered by Mantis Bugtracker