Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000280 [Resin] minor always 06-21-05 00:00 11-02-05 14:43
Reporter sam View Status public  
Assigned To
Priority urgent Resolution fixed  
Status closed   Product Version 3.0.13
Summary 0000280: stdout-log rollover at startup
Description RSN-315
(rep by B Au)

I have also see cases where resin 3 rollover the stdout.log at startup
time even when its size is less than rollover-size.
I can reproduce this every time with a stdout.log that's 100 mb in size.
 
Additional Information
Attached Files

- Relationships

- Notes
(0000317)
billa
06-21-05 00:00

By the way, here are my rollover-size and rollover-period settings when I reproduce the problem:

rollover-size="2048mb" rollover-period="1M"
 
(0000318)
ferg
06-21-05 00:00

The default rollover size is 100mb (in RotateLog.java).

It looks like the default rotate size is causing the log rollover before the new configured size has been read, i.e. a configuration startup issue.
 
(0000319)
billa
06-21-05 00:00

Resin 2 has this problem and I was told that it probably won't be fixed there. I am disappointed in discovering that Resin 3 also has this problem.

In addition, will we ever be able to set rollover-size to -1 to disable log rollover?
 
(0000320)
ferg
06-21-05 00:00

The RotateStream default values are now infinite size and period.
 

- Issue History
Date Modified Username Field Change
06-21-05 00:00 sam New Issue
11-02-05 00:00 administrator Fixed in Version  => 3.0.15
11-02-05 14:43 ferg Status resolved => closed


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
33 total queries executed.
31 unique queries executed.
Powered by Mantis Bugtracker