Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002635 [Resin] major always 04-28-08 17:20 04-01-08 13:38
Reporter mauricev View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.1.5
Summary 0002635: Resin cannot see many jsp files unless it has write permissions to them
Description This is a resubmission of http://bugs.caucho.com/view.php?id=2107. [^] After I reported that bug, resin spontaneously began working fine as if the problem never existed. Just recently, I upgraded to resin to 3.1.5 and the write permission bug is back although it may be worse now because giving the files write permission no longer helps.
Additional Information Note that this only affects some of the jsp files. Some work; some do not, which ones appears to be random.

Here's a list of what you requested
-rwxrwxr-x 1 halllab halllab 5184 2008-03-12 15:37 browse.jsp
-rwxrwxr-x 1 halllab halllab 9681 2008-03-12 15:37 feedback_image.jsp
-rwxrwxr-x 1 halllab halllab 9615 2008-03-12 15:37 feedback.jsp
-rwxrwxr-x 1 halllab halllab 6132 2008-03-12 15:37 feedbackRetrive.jsp
-rwxrwxr-x 1 halllab halllab 7878 2008-03-12 15:37 feedbackSend.jsp
-rwxrwxr-x 1 halllab halllab 234 2008-03-12 15:37 fullImage.jsp
-rwxrwxr-x 1 halllab halllab 9528 2008-03-12 15:37 image.jsp
-rwxrwxr-x 1 halllab halllab 8859 2008-03-12 15:37 imageList.jsp
-rw-r--r-- 1 halllab halllab 8609 2008-03-12 15:37 imageListOfName.jsp
-rw-r--r-- 1 halllab halllab 8585 2008-03-12 15:37 imageListOfRegion.jsp
-rwxrwxr-x 1 halllab halllab 8645 2008-03-12 15:37 imgList.jsp
-rw-r--r-- 1 resin resin 1507 2008-04-28 17:48 index.jsp
-rwxrwxr-x 1 halllab halllab 5606 2008-03-12 15:37 ListByRegion.jsp
-rwxrwxr-x 1 halllab halllab 5873 2008-03-12 15:37 member.jsp
-rwxrwxr-x 1 halllab halllab 34069 2008-03-12 15:37 montage_browser_test.jsp
-rwxrwxr-x 1 halllab halllab 5668 2008-03-12 15:37 searchByAge.jsp
-rwxrwxr-x 1 halllab halllab 6921 2008-03-12 15:37 searchByName.jsp
-rwxrwxr-x 1 halllab halllab 5522 2008-03-12 15:37 searchByRegion.jsp
-rwxrwxr-x 1 halllab halllab 13055 2008-03-12 15:37 searchByTissue.jsp
-rwxrwxr-x 1 halllab halllab 14601 2008-03-12 15:37 searchImage.jsp
-rwxrwxr-x 1 halllab halllab 12874 2008-03-12 15:37 searchImg.jsp
-rwxrwxr-x 1 halllab halllab 7252 2008-03-12 15:37 searchWorm.jsp
-rwxrwxr-x 1 halllab halllab 6281 2008-03-12 15:37 selectRegion.jsp
-rwxrwxr-x 1 halllab halllab 22 2008-03-12 15:37 test.jsp
-rwxrwxr-x 1 halllab halllab 6662 2008-03-12 15:37 wormList.jsp

owning directory
drwsrwsr-x 14 halllab halllab 4096 2008-04-28 20:02 ROOT

WEB-INF and subdirectories
drwxrwxrwx 5 halllab halllab 4096 2005-05-26 01:03 WEB-INF
drwxrwsrwx 3 halllab halllab 4096 2008-04-28 16:05 work
drwxrwsrwx 3 halllab halllab 4096 2008-04-28 19:49 _jsp

The result of a request of execution of wormList.jsp (in the above listing) is attached.

But now even giving this file write permission to everyone doesn't help. Resin still still can't "find" it.
Attached Files  no_write_permission_no_access.jpg [^] (33,206 bytes) 04-28-08 17:20
 notfoundbug.pdf [^] (88,123 bytes) 04-01-08 11:05
 evenmorelogging.rtf [^] (2,419 bytes) 04-01-08 11:12

- Relationships

- Notes
(0003022)
ferg
04-01-08 09:10

Can you add any stack trace for the error (the attachment was corrupted).
 
(0003023)
mauricev
04-01-08 11:05

I'm not sure why the picture was corrupted. I removed resin and reinstalled it. Now it cannot find any jsp file at all. I am attaching a PDF showing that as well as the debug log. I'm not exactly sure what you mean by a stack trace.
 
(0003024)
ferg
04-01-08 11:12

Can you just mail it to ferg@caucho.com? It looks like the uploads are getting corrupted on mantis.
 
(0003025)
mauricev
04-01-08 11:12

I set the debug log to "all" and am now uploading it. It just says it can't find the page, despite that it is there.
 
(0003026)
mauricev
04-01-08 12:18

The problem is solved. EVERYTHING contained in the ROOT/WEB-INF/work/ directory must be writable by the resin user.
 
(0003027)
ferg
04-01-08 13:38

jsp/1955
 

- Issue History
Date Modified Username Field Change
04-28-08 17:20 mauricev New Issue
04-28-08 17:20 mauricev File Added: no_write_permission_no_access.jpg
04-01-08 09:10 ferg Note Added: 0003022
04-01-08 11:05 mauricev Note Added: 0003023
04-01-08 11:05 mauricev File Added: notfoundbug.pdf
04-01-08 11:06 mauricev Issue Monitored: mauricev
04-01-08 11:12 ferg Note Added: 0003024
04-01-08 11:12 mauricev Note Added: 0003025
04-01-08 11:12 mauricev File Added: evenmorelogging.rtf
04-01-08 12:18 mauricev Note Added: 0003026
04-01-08 13:38 ferg Note Added: 0003027
04-01-08 13:38 ferg Assigned To  => ferg
04-01-08 13:38 ferg Status new => closed
04-01-08 13:38 ferg Resolution open => fixed
04-01-08 13:38 ferg Fixed in Version  => 3.1.6


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
43 total queries executed.
31 unique queries executed.
Powered by Mantis Bugtracker