Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002377 [Quercus] major always 01-01-08 06:36 05-13-08 18:40
Reporter gjvc View Status public  
Assigned To nam
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0002377: resin-3.1.s080126, mediawiki 1.11.0, fails after some use
Description This is tricky to describe. I'll start with the basics.
Java 1.6.03, resin 3.1.s080126, mediawiki 1.11.0

Set up mediawiki, use it for a bit, and it stops rendering all links.

This issue is independent of the database because it happens with both postgres 8.2.6/postgresql-8.2-507.jdbc4.jar and mysql 4.0.18/mysql-connector-java-3.1.14-bin.jar.

resin 3.1.3 and mediawiki 1.10 runs ok and hits the above problem
resin-3.1.s080126 and mediawiki 1.11 runs ok and hits the above problem -- see issue
resin 3.1.3 and mediawiki 1.11 doesn't run -- see issue
Additional Information
Attached Files

- Relationships

- Notes
(0002696)
gjvc
01-01-08 06:41

crap. above, where i say 'see issue' i mean 'see issue 0002359'

Also, the raw HTML is not being escaped.
 
(0002697)
nam
01-01-08 13:13

When the links are not rendered anymore, does a restart of the server correct it?
 
(0002698)
gjvc
01-01-08 14:19

Hi,

Yes, killing and restarting resin does correct it. ;-/


gjvc
 
(0002705)
gjvc
02-01-08 01:32
edited on: 02-06-08 01:11

Hi,

Still unreliable with resin-3.1.s080130, I'm afraid.

And no luck with resin-3.1.s080205 either :-(


gjvc

 
(0002740)
mo
02-08-08 13:12

Hi gjvc

I am very interested in reproducing this issue. I have been testing
MediaWiki with the current trunk and I have not run into the problem
you describe. I am running in interpreted mode and I initialized a
mysql database for this mediawiki install.

I wonder if you could download the most recent snapshot and see
if you can still reproduce the problem. There is a new snapshot
for 2008/02/08:

http://www.caucho.com/download/index.xtp [^]

Also, when you state "the raw HTML is not being escaped" are you
talking about HTML in this bug tracker or are you talking
about HTML inserted into a MediaWiki entry field?
 
(0002896)
mo
03-25-08 14:12

A new snapshot released on 2008/03/20 may contain a fix for this problem.
A recently discovered bug in the regexp code may be the cause of this failure,
but testing is needed to discover if this bug has been fixed by the regexp change.
 
(0002932)
gjvc
03-02-08 22:39
edited on: 03-03-08 05:46

Hi,

I tried the latest snapshot 20080320, but I run into the bug 002546 instead. Anxiously awaiting a fix to that so I can check the fix to this one :-)


gjvc

 
(0002936)
gjvc
04-01-08 03:51

GOOD NEWS! This appears to be fixed in resin-3.1.s080331.
 

- Issue History
Date Modified Username Field Change
01-01-08 06:36 gjvc New Issue
01-01-08 06:41 gjvc Note Added: 0002696
01-01-08 13:13 nam Note Added: 0002697
01-01-08 14:19 gjvc Note Added: 0002698
02-01-08 01:32 gjvc Note Added: 0002705
02-05-08 11:56 mo Status new => assigned
02-05-08 11:56 mo Assigned To  => mo
02-06-08 01:11 gjvc Note Edited: 0002705
02-08-08 13:12 mo Note Added: 0002740
03-25-08 14:12 mo Note Added: 0002896
03-28-08 13:20 mo Assigned To mo => nam
03-02-08 22:39 gjvc Note Added: 0002932
03-03-08 05:46 gjvc Note Edited: 0002932
04-01-08 03:51 gjvc Note Added: 0002936
05-13-08 18:40 ferg Status assigned => closed
05-13-08 18:40 ferg Resolution open => fixed
05-13-08 18:40 ferg Fixed in Version  => 3.1.6


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
47 total queries executed.
35 unique queries executed.
Powered by Mantis Bugtracker