Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000230 [Resin] minor always 06-01-05 00:00 06-30-05 00:00
Reporter admin View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.0.13
Summary 0000230: jira email not working to receiver outside caucho.com
Description RSN-253
The caucho.com mail server refuses to send email generated by jira to a party outside of caucho.com (Relay access denied)

An error has occurred with sending the test email:
com.atlassian.mail.MailException: javax.mail.SendFailedException: Sending failed;
  nested exception is:
    javax.mail.SendFailedException: Invalid Addresses;
  nested exception is:
    javax.mail.SendFailedException: 554 <hogwarts@yahoo.com>: Relay access denied

    at com.atlassian.mail.server.impl.SMTPMailServerImpl.send(SMTPMailServerImpl.java:152)
    at com.atlassian.jira.web.action.admin.mail.SendTestMail.doExecute(SendTestMail.java:72)
    at webwork.action.ActionSupport.execute(ActionSupport.java:153)
    at com.atlassian.jira.action.JiraActionSupport.execute(JiraActionSupport.java:46)
    at webwork.dispatcher.GenericDispatcher.executeAction(GenericDispatcher.java:131)
    at com.atlassian.jira.web.dispatcher.JiraServletDispatcher.service(JiraServletDispatcher.java:186)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:90)
    at com.caucho.server.dispatch.ServletFilterChain.doFilter(ServletFilterChain.java:99)
    at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
    at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
    at com.atlassian.jira.web.filters.SitemeshExcludePathFilter.doFilter(SitemeshExcludePathFilter.java:36)
    at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:70)
    at com.atlassian.seraph.filter.SecurityFilter.doFilter(SecurityFilter.java:168)
    at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:70)
    at com.atlassian.seraph.filter.LoginFilter.doFilter(LoginFilter.java:177)
    at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:70)
    at com.atlassian.util.profiling.filters.ProfilingFilter.doFilter(ProfilingFilter.java:132)
    at com.atlassian.jira.web.filters.ProfilingAndErrorFilter.doFilter(ProfilingAndErrorFilter.java:25)
    at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:70)
    at com.atlassian.jira.web.filters.ActionCleanupDelayFilter.doFilter(ActionCleanupDelayFilter.java:37)
    at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:70)
    at com.atlassian.johnson.filters.JohnsonFilter.doFilter(JohnsonFilter.java:91)
    at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:70)
    at com.atlassian.jira.web.filters.gzip.GzipFilter.doFilter(GzipFilter.java:72)
    at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:70)
    at com.atlassian.core.filters.AbstractEncodingFilter.doFilter(AbstractEncodingFilter.java:36)
    at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:70)
    at com.caucho.server.cache.CacheFilterChain.doFilter(CacheFilterChain.java:189)
    at com.caucho.server.webapp.WebAppFilterChain.doFilter(WebAppFilterChain.java:163)
    at com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:208)
    at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:259)
    at com.caucho.server.port.TcpConnection.run(TcpConnection.java:341)
    at com.caucho.util.ThreadPool.runTasks(ThreadPool.java:490)
    at com.caucho.util.ThreadPool.run(ThreadPool.java:423)
    at java.lang.Thread.run(Thread.java:595)
Caused by: javax.mail.SendFailedException: Sending failed;
  nested exception is:
    javax.mail.SendFailedException: Invalid Addresses;
  nested exception is:
    javax.mail.SendFailedException: 554 <hogwarts@yahoo.com>: Relay access denied

    at javax.mail.Transport.send0(Transport.java:219)
    at javax.mail.Transport.send(Transport.java:81)
    at alt.javax.mail.TransportImpl.send(TransportImpl.java:18)
    at com.atlassian.mail.server.impl.SMTPMailServerImpl.send(SMTPMailServerImpl.java:138)
    ... 34 more
Additional Information
Attached Files

- Relationships

- Notes
(0000263)
pburleson
06-01-05 00:00

Sounds like you enable local relay in your mail server. That would explain why I haven't been getting update emails.

What email server are you using? What OS?
 
(0000264)
sam
06-01-05 00:00

Had to specify `localhost' not `caucho.com' for the SMTP server in the JIRA config.
 

- Issue History
Date Modified Username Field Change
06-01-05 00:00 admin New Issue
11-30-05 00:00 administrator Fixed in Version  => 3.0.14


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
31 total queries executed.
29 unique queries executed.
Powered by Mantis Bugtracker