Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000200 [Resin] minor always 05-20-05 00:00 11-01-05 14:43
Reporter sam View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.0.13
Summary 0000200: mod_caucho losing configuration information
Description RSN-207
(rep by K Fetterman)

http://www.caucho.com/quercus/bugtrack/view.xtp?bugreport_id=2547 [^]
Sometimes I see raw jsp.
I confirmed that the problem still exists in 3.0.13.

After stopping resin, I went through and completely cleaned out the
system. This included, restoring the original httpd.conf, deleting the
mod_caucho.so, deleting the cache, sessions under server root, and the
tmp, work and sessions directories under each web app.

I then did a make clean, ./configure --with-apxs, make and make install
in the /usr/local/resin-pro-3.0.13 directory.

After bring the servers up and confirming the servers were running my
webapps, I shut them both (httpd and resin) down in different order and
then restarted them. I was able to recreate the problem.

I stopped apache httpd, deleted the file /tmp/localhost_6802 and started
httpd again. Now it works. All of my apps are running and don't get the
raw JSP even if I click reload multiple times.

I did some further testing. It appears that the problem occurs when
both resin and apache httpd are stopped.

I stopped both.

I then started resin and let it fully load. Once resin was fully
loaded, I then started apache httpd. The problem returned.

To fix it, I stopped apache httpd, deleted the file /tmp/localhost_6802
and start httpd again. The problem went away. Notice that I didn't
have to restart resin.

Once when I was testing, after stopping and starting both httpd and
resin, I noticed that the problem didn't occur. Well, I think I figured
out why. If I stop httpd first and then resin, the problem occurs when
I start them up (in the order I mentioned above, ie, resin first and
then httpd). If I stop resin first and then httpd, the problem doesn't
occur when I start them again.
Additional Information Resin Enterprise 3 WS
Apache httpd: Apache/2.0.46
Resin 3 snapshot(5/16/05)
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
05-20-05 00:00 sam New Issue
11-01-05 00:00 administrator Fixed in Version  => 3.0.14
11-01-05 14:43 ferg Status resolved => closed


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
28 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker