Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000141 [Resin] minor always 05-05-05 00:00 02-03-06 10:13
Reporter stevea View Status public  
Assigned To ferg
Priority high Resolution fixed  
Status closed   Product Version
Summary 0000141: Windows 2003 Resin service installation.
Description RSN-135
The bug is simply when you use the Caucho tutorial on how setup your resin services doesnt work for most of win2k3 users. I'm a programmer and we actually test resin to see if it worth a shoot. We passed 1 week to try setup and stuff to make everything work like a charm.

There few step to help you, cause since I didn't find this solution in here or mixed through ALOT of post, ill try to resume them here :

1. SET YOUR ENVIRONNEMENT VARIABLE (LOCAL + SYSTEM)

   JAVA_HOME = PATH://TO/JAVA/JDK [^]
   RESIN_HOME = PATH://TO/RESIN [^]

2. INSTALL THE RESIN SERVICE (httpd.exe -install)
3. OPEN REGEDIT TO MANUALLY EDIT THE SERVICE OPTION.
   (I.E) :: HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Resin
   CHANE THE 'ImagePath' TO SOMETHING EXACTLY LIKE THIS :
   
   %RESIN_HOME%\bin\httpd.exe -service -conf "D:\resin-pro-3.0.12\conf\resin.conf" -Xrs -stdout "stdout.log" -stderr "stderr.log"

Reboot or Save and start your service. (Make sure that your resin work in command line (Manually, not service) so you can know there is no configuration problem to fix at the service installation time).

You gotta blame the one who worked on the Default Service installation option, the exact poroblem is within the argument. The way the httpd.exe put the argument into the ImagePath value in registry is wrong.

The way to do it is : file.exe -option "option argument 0000001" -option2 "option stuff 0000002"

Since this costed us more in configuration and debug than buying the ReSin license itself... We though that sharing this solution with you guy would be a good idea........

Yours Truly
Steve Arbour.
Additional Information Windows 2003 Entreprise Server + JDK 5.0 Update 3 + ReSin as standalone 3.0.12.
Quad Xeon + 1 GB ram etc.. Good system.
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
05-05-05 00:00 stevea New Issue
02-03-06 10:13 ferg Assigned To  => ferg
02-03-06 10:13 ferg Status acknowledged => closed
02-03-06 10:13 ferg Resolution open => fixed
02-03-06 10:13 ferg version 3.0.12 =>
02-03-06 10:13 ferg Fixed in Version  => 3.0.18


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
30 total queries executed.
28 unique queries executed.
Powered by Mantis Bugtracker