Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000002 [Resin] major always 11-23-05 10:01 11-01-05 10:18
Reporter ferg View Status @0@  
Assigned To ferg
Priority high Resolution no change required  
Status closed   Product Version
Summary 0000002: jsp:output with jsp file
Description (rep by Gary Doughty)

When moving from 3.0.14 to 3.0.15 when trying to complile a jspx file, we now get the following:
 
com.caucho.jsp.JspLineParseException: /WEB-INF/jsp/tiles/layout/brand/newfoo.jspx:10: jsp:output is only allowed in jspx files.
        at com.caucho.jsp.java.JspNode.error(JspNode.java:1415)
        at com.caucho.jsp.java.JspNode.error(JspNode.java:1406)
        at com.caucho.jsp.java.JspOutput.addAttribute(JspOutput.java:74)
        at com.caucho.jsp.java.JavaJspBuilder.attribute(JavaJspBuilder.java:342)
        at com.caucho.jsp.JspParser.parseOpenTag(JspParser.java:1234)
        at com.caucho.jsp.JspParser.parseNode(JspParser.java:481)
        at com.caucho.jsp.JspParser.parseJsp(JspParser.java:328)
        at com.caucho.jsp.JspParser.parse(JspParser.java:252)
        at com.caucho.jsp.JspCompilerInstance.generate(JspCompilerInstance.java:448)
        at com.caucho.jsp.JspCompilerInstance.compile(JspCompilerInstance.java:358)
        at com.caucho.jsp.JspManager.compile(JspManager.java:213)
        at com.caucho.jsp.JspManager.createPage(JspManager.java:157)
        at com.caucho.jsp.JspManager.createPage(JspManager.java:137)
        at com.caucho.jsp.PageManager.getPage(PageManager.java:235)
        at com.caucho.jsp.PageManager.getPage(PageManager.java:153)
        at com.caucho.jsp.QServlet.getSubPage(QServlet.java:292)
        at com.caucho.jsp.QServlet.getPage(QServlet.java:210)
        at com.caucho.server.dispatch.PageFilterChain.compilePage(PageFilterChain.java:186)
        at com.caucho.server.dispatch.PageFilterChain.doFilter(PageFilterChain.java:123)
        at com.caucho.server.webapp.DispatchFilterChain.doFilter(DispatchFilterChain.java:115)
        at com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:229)
        at com.caucho.server.webapp.RequestDispatcherImpl.forward(RequestDispatcherImpl.java:268)
        at com.caucho.server.webapp.RequestDispatcherImpl.forward(RequestDispatcherImpl.java:106)
        at org.apache.struts.action.RequestProcessor.doForward(RequestProcessor.java:1063)
        at org.apache.struts.tiles.TilesRequestProcessor.doForward(TilesRequestProcessor.java:263)
        at com.foo.struts.processor.RequestProcessorAdapter.doForward(RequestProcessorAdapter.java:47)
        at org.apache.struts.tiles.TilesRequestProcessor.processTilesDefinition(TilesRequestProcessor.java:239)
        at com.foo.struts.processor.RequestProcessorAdapter.processTilesDefinition(RequestProcessorAdapter.java:330)
        at com.foo.web.action.RequestProcessorImpl.processTilesDefinition(RequestProcessorImpl.java:126)
        at org.apache.struts.tiles.TilesRequestProcessor.processForwardConfig(TilesRequestProcessor.java:302)
        at com.foo.struts.processor.RequestProcessorAdapter.processForwardConfig(RequestProcessorAdapter.java:290)
        at com.foo.web.action.RequestProcessorImpl.processForwardConfig(RequestProcessorImpl.java:103)
        at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:229)
        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1194)
        at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:115)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:92)
        at com.caucho.server.dispatch.ServletFilterChain.doFilter(ServletFilterChain.java:106)
        at com.foo.hibernate.HibernateFilter.doFilter(HibernateFilter.java:55)
        at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:70)
        at com.foo.servlet.filter.PrincipalFilter.doFilter(PrincipalFilter.java:44)
        at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:70)
        at com.foo.servlet.filter.EmailPopupCookieFilter.doFilter(EmailPopupCookieFilter.java:158)
        at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:70)
        at com.foo.servlet.filter.AdrefCookieFilter.doFilter(AdrefCookieFilter.java:117)
        at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:70)
        at com.foo.servlet.filter.TrackingFilter.doFilter(TrackingFilter.java:190)
        at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:70)
        at com.caucho.server.cache.CacheFilterChain.doFilter(CacheFilterChain.java:209)
        at com.caucho.server.webapp.WebAppFilterChain.doFilter(WebAppFilterChain.java:178)
        at com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:229)
        at com.caucho.server.hmux.HmuxRequest.handleRequest(HmuxRequest.java:414)
        at com.caucho.server.port.TcpConnection.run(TcpConnection.java:386)
        at com.caucho.util.ThreadPool.runTasks(ThreadPool.java:490)
        at com.caucho.util.ThreadPool.run(ThreadPool.java:423)
        at java.lang.Thread.run(Thread.java:595)

Since it is a jspx, it does not seem like this should be happening. Is this a bug in the new version?
 
Additional Information
Attached Files

- Relationships

- Notes
(0000491)
ferg
11-01-05 10:15

The configuration file had remapped .jspx to resin-jsp, not resin-jspx, so the .jspx files were not actually using jspx syntax.
 

- Issue History
Date Modified Username Field Change
11-23-05 10:01 ferg New Issue
11-23-05 10:02 ferg Status new => acknowledged
11-01-05 08:48 ferg Status acknowledged => assigned
11-01-05 08:48 ferg Assigned To  => ferg
11-01-05 10:15 ferg Status assigned => resolved
11-01-05 10:15 ferg Resolution open => no change required
11-01-05 10:15 ferg Note Added: 0000491
11-01-05 10:18 ferg Status resolved => closed


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
28 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker