Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005085 [Resin] minor always 05-18-12 16:37 01-16-13 13:41
Reporter rickHigh View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0005085: RPM broken for CentOS6.2 and later versions of Fedora
Description was provided by openssl-0.9.8b in older Fedora distribution (8,7,6).
It seems our software was compiled and dynamically linked with an old distribution
and cannot run on more recent distribution.

The workaround seems to be to recompile the software from source.

(I have not tried this yet.)

Additional Information Tried setting up OpenSSL support for admin to see if OpenSSL support was causing the issue with JNI.

Caused by: java.lang.UnsatisfiedLinkError: /usr/local/share/resin-4.0.27/libexec64/ cannot open shared object file: No such file or directory
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary0(

I get the above error instead.

It appears we are looking for

This machine has CentOS 6.2 on it and I did an instal of openssl, we get this:

# ls /usr/lib64/libssl*
/usr/lib64/ /usr/lib64/ /usr/lib64/

There is a but no
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
05-18-12 16:37 rickHigh New Issue
01-16-13 13:41 ferg Assigned To  => ferg
01-16-13 13:41 ferg Status new => closed
01-16-13 13:41 ferg Resolution open => fixed
01-16-13 13:41 ferg Fixed in Version  => 4.0.33

Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
27 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker