Mantis - Resin
Viewing Issue Advanced Details
5085 minor always 05-18-12 16:37 01-16-13 13:41
none 4.0.33  
0005085: RPM broken for CentOS6.2 and later versions of Fedora was provided by openssl-0.9.8b in older Fedora distribution (8,7,6).
It seems our software was compiled and dynamically linked with an old distribution
and cannot run on more recent distribution.

The workaround seems to be to recompile the software from source.

(I have not tried this yet.)

Tried setting up OpenSSL support for admin to see if OpenSSL support was causing the issue with JNI.

Caused by: java.lang.UnsatisfiedLinkError: /usr/local/share/resin-4.0.27/libexec64/ cannot open shared object file: No such file or directory
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary0(

I get the above error instead.

It appears we are looking for

This machine has CentOS 6.2 on it and I did an instal of openssl, we get this:

# ls /usr/lib64/libssl*
/usr/lib64/ /usr/lib64/ /usr/lib64/

There is a but no

There are no notes attached to this issue.