Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000305 [Resin] minor always 07-12-05 00:00 11-30-05 14:43
Reporter pburleson View Status public  
Assigned To
Priority high Resolution no change required Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.0.15 Product Version 3.0.13
  Product Build 3.0.13
Summary 0000305: Classloader issue when deploying alongside a RAR
Description RSN-344
I deployed a RAR that shared some of the same libs that my WARs do, and it appears the RAR's classloader pollutes the WAR's classloader. Or at least, the WAR ends up loading classes from the RAR's classpath and then subsequently can't find things that are only in the WAR.

I thought all deployments were supposed to be protected from each other?
Steps To Reproduce
Additional Information Windows JDK 5.0_03
Attached Files

- Relationships

- Notes
(0000344)
ferg
07-12-05 00:00

The webapps are distinct from each other.

However, deployed RARs are intended to be shared in the environment they're deployed to, i.e. a RAR deployed in a web-app would be a JCA resource that would be used by the web-app. A RAR deploy in a host would be used in all of the web-apps.

In other words, the deployed RAR will be added to the environment's classloader as if they were put in the WEB-INF/lib.
 

- Issue History
Date Modified Username Field Change
07-12-05 00:00 pburleson New Issue
11-30-05 00:00 administrator Fixed in Version  => 3.0.15
11-30-05 14:43 ferg Status resolved => closed


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker