Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000290 [Resin] minor always 06-30-05 00:00 11-30-05 14:43
Reporter bertano View Status public  
Assigned To
Priority urgent Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.0.15 Product Version 2.1.x
  Product Build 2.1.x
Summary 0000290: Time Taken (time of a request) in milliseconds in the access-log?
Description RSN-329
Time-Taken Problem,

we need(!) for our statistics a more exactly resolution of time.
The IIS can measure in millisecond, apache too.
In my humble opinion the Resin-Webserver is a reliable Webserver and can better scale with jsp-serving than an Apache-Resin-servlet-Kombination or IIS/Resin Kombination. The one and only problem is still the time-taken-option in the access log.
There are mostly only two entries: 0 or 1. Our Server is fast enough to server between 0 and 1 second per Request. So the statistic has no information in that point of view - but the CEO wants to have that information.

_Please_ for a newer Release let the Resin-logger measure the time-taken in milliseconds like all the other Webservers do since long time ago.

Ciao,
Bert
Steps To Reproduce
Additional Information W2003 Server, 8 GB RAM, 2xXEON 2GHz, 250 GB HD RAID1, WebServer(IIS)/JSP-Appl.Server(Resin) ~ 300.000 Request /week
Attached Files

- Relationships

- Notes
(0000325)
ferg
06-30-05 00:00

server/021s

The new %D format will give the time in microseconds.
 

- Issue History
Date Modified Username Field Change
06-30-05 00:00 bertano New Issue
11-30-05 00:00 administrator Fixed in Version  => 3.0.15
11-30-05 14:43 ferg Status resolved => closed


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker