Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000278 [Resin] minor always 06-20-05 00:00 11-30-05 14:43
Reporter quotemedia View Status public  
Assigned To
Priority urgent Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.0.15 Product Version 3.0.13
  Product Build 3.0.13
Summary 0000278: cmp cache-timeout not always observed
Description RSN-313
in resin 3.x, i have the attached ejb file. there is a many-to-many cmr relationship between topics and newsItems. The topics bean has a cache-timout of 5m, whereas the newsItem bean has a cache-timeout of 15m. I have a simple process:

Topic topic = topicHome.findByPrimaryKey(topicString);
Collection newsItems = topic.getNewsItemsByCMR();

After observing the sql being executed using <spy>, i see the following results:

1. the topic bean seems to be cached indefinitely and ignores the 5m cache-timeout. (i never see the sql repeated)
2. the newsItem cmr sql is cached only if the result set is less than a certain small size (see RSN-312), otherwise the sql is executed on every call. if the size is small enough and the results are cached, then it obeys the 15 min cache-timeout and only executes the cmr sql after 15 minutes have passed.

christian
Steps To Reproduce
Additional Information resin 3.x pro
Attached Files

- Relationships

- Notes
(0000313)
ferg
06-20-05 00:00

ejb/0k50
 

- Issue History
Date Modified Username Field Change
06-20-05 00:00 quotemedia New Issue
11-30-05 00:00 administrator Fixed in Version  => 3.0.15
11-30-05 14:43 ferg Status resolved => closed


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker