Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002129 [Resin] minor always 10-02-07 07:24 12-27-07 12:52
Reporter ferg View Status public  
Assigned To ferg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.0.25 Product Version 3.0.23
  Product Build
Summary 0002129: isapi timing issues
Description (rep by Ed Hollingsworth)

vRecently, we?ve been noticing some questionable behavior on one of our clustered deployments of Resin 3.0.23, using IIS for the web server in conjunction with the Resin ISAPI filter. Virtual Host entries will seem to ?appear? spontaneously on the caucho-status page. I am including a screenshot for your review. The Virtual Host section in the middle of the page is not something we manually configured. The referenced IP address (.113) is actually the Virtual IP that our F5 BigIP load balancer responds to for the cluster, then delegating to the two IP addresses you see in the ?configuration cluster? and under the ?default virtual host? section. I am curious how the .113 entry gets in there; the entries when they appear also seem to disappear after a period of time as well? We also sometimes see entries for the domain name (i.e. myhost.mydomain.com:80 or :443).
 
The main concern is that we sometimes see inconsistent/unreliable loading of actual web applications on these machines that seem to coincide with when these ?mystery entries? appear on the caucho-status page. Unfortunately, I cannot say that this happens 100% of the time, but I wanted to find out if you guys thought there could be a correlation? At times when these entries are present, and then we attempt to hit a legitimate webapp deployed on one of the clustered instances of Resin, we will get either a bogus page load (images don?t resolve properly and other stylesheet inconsistencies), or a ?Server is currently unavailable or down for maintenance? message. I wondered if the bogus virtual host is trying to process the request, if it won?t see the deployed webapp? This problem appears to go away by itself after a period of time, but the inconsistent behavior is obviously disconcerting.
 
Any insight you might have as to how the ISAPI filter seems to pick up these additional entries (and then lose them again) would be greatly appreciated!
 
Steps To Reproduce
Additional Information
Attached Files

- Relationships
related to 0001879closed ferg isapi_srun.dll corrupted? 

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
10-02-07 07:24 ferg New Issue
11-05-07 12:11 ferg Assigned To  => ferg
11-05-07 12:11 ferg Status new => closed
11-05-07 12:11 ferg Resolution open => fixed
11-05-07 12:11 ferg Fixed in Version  => 3.0.25
11-05-07 12:11 ferg Description Updated
12-27-07 12:52 sam Relationship added related to 0001879


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
32 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker