Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000193 [Resin] minor always 05-19-05 00:00 11-30-05 14:43
Reporter ferg View Status public  
Assigned To
Priority urgent Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.0.14 Product Version 3.0.14
  Product Build 3.0.14
Summary 0000193: mod_caucho restart issue
Description RSN-195
(rep by Keith Fetterman)

I don't think this problem is fixed in 3.0.13. I have been running into a problem where I sometimes get raw JSP source. I couldn't figure it out. It would work fine. Then the next day, the problem would be back.

If I ran my site using the httpd server in resin. The site worked great. If I ran it with apache2, I would sometimes get the correct page but usuually, I would get raw jsp source.

Well the bug report tipped me off.

Here is what I discovered.

- When both the resin and apache httpd servers are stopped AND the httpd server is stopped first, the problem occurs when both servers are started again.

- If both resin and apache httpd servers are stopped AND the resin server is stopped first, thhe problem does not occur.

In both cases, I started the resin server first and then the httpd server.

Once the problem occurs, the only way I could clear it was to 1) stop the httpd server, 2) delete the file /tmp/localhost_6802, 3) restart the httpd server.

This problem is occuring in the Resin Professional 3.0.s050516 and Resin Professional 3.0.13. My configuration if Red Hat Enterprise 3 WS and the Apache 2 that is included with the RHE3, Apache/2.0.46.

Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
05-19-05 00:00

So, is it really fixed? I have the same problem in 3.0.13, please tell me which version has no such bug???

- Issue History
Date Modified Username Field Change
05-19-05 00:00 ferg New Issue
11-30-05 00:00 administrator Fixed in Version  => 3.0.14
11-30-05 14:43 ferg Status resolved => closed

Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker