Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000170 [Resin] minor always 05-15-05 00:00 11-30-05 14:44
Reporter suresh View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.0.14 Product Version 3.0.12
  Product Build 3.0.12
Summary 0000170: wrapper.sh.in does not set -Dresin.home to RESIN_HOME, but rather SERVER_HOME
Description RSN-170
This is a major issue if you attempt to separate Resin's home directory from the server-root directory. When doing so, the line # 561 of wrapper.pl.in reads:

    $JAVA_ARGS .= " -Dresin.home=$SERVER_ROOT $EXTRA_JAVA_ARGS";

The problem here is that nearly everything at runtime (licenses, config files, etc.) use "resin.hom" definition and if set incorrectly defeats the entire purpose of separating Resin's home from Server root.

This line should probably read:

    $JAVA_ARGS .= " -Dresin.home=$RESIN_HOME $EXTRA_JAVA_ARGS";
Steps To Reproduce
Additional Information This is a problem in Unix & Windows. While you can modify script in wrapper.pl.in on Unix, you can't modify in Windows because of httpd.exe.
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
05-15-05 00:00 suresh New Issue
11-30-05 00:00 administrator Fixed in Version  => 3.0.14
11-30-05 14:44 ferg Status resolved => closed


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
28 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker