Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000147 [Resin] minor always 05-06-05 00:00 11-30-05 14:44
Reporter david@eyefinity.com View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.0.14 Product Version 3.0.13
  Product Build 3.0.13
Summary 0000147: Named log going to path="stdout:" gets redirected by <stdout-log>
Description RSN-141
Debug output to the console (path="stdout:") in resin.conf via a named <log> and <resin:log> winds up getting redirected after a <stdout-log> entry. For example:

<host host-name="hogwarts.com">
  <log name="com.hogwarts.resin.boot" level="info" path="stdout:" timestamp="[%H:%M:%S.%s] "/>
  <resin:log name="com.hogwarts.resin.boot">Now you see me...</resin:log>
  <stdout-log path="c:/hogwarts/stdout.log"/>
  <resin:log name="com.hogwarts.resin.boot">...Now you don't!</resin:log>
</host>

I would expect stdout-log only to apply to things written in code with System.out.println() and possibly un-named logs. I would expect the scenario described above to continue to go to the console. This is useful for monitoring the status of server startup if you have a lot of (or slow starting) webapps.
Steps To Reproduce
Additional Information Windows XP
Attached Files

- Relationships

- Notes
(0000175)
ferg
05-06-05 00:00

Currently, that behavior is the designed/intended behavior, i.e. we did think about that and chose that behavior.

On the other hand, the requested behavior might be more logical and useful.
 
(0000176)
sam
05-06-05 00:00

Possibly:

<system-out path="..."/>
<system-err path="..."/>

Capture the System.out and System.err streams, but not stdout: or stderr: from Vfs.
 
(0000177)
ferg
05-06-05 00:00

server/020m
 
(0000178)
david@eyefinity.com
05-06-05 00:00

Can you clarify on what the fix is? Did you implement system-out/-err as desicribed by Sam or some other fix?
 

- Issue History
Date Modified Username Field Change
05-06-05 00:00 david@eyefinity.com New Issue
11-30-05 00:00 administrator Fixed in Version  => 3.0.14
11-30-05 14:44 ferg Status resolved => closed


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
33 total queries executed.
31 unique queries executed.
Powered by Mantis Bugtracker