Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000987 [Resin] block always 03-11-06 06:02 03-02-06 11:09
Reporter volga View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.0.18
Summary 0000987: Transaction Manager throws NullPointer Exception when starting a transaction
Description When updating an Entity bean field (formerly null), it is not updated. Further access returns null. No Exception message in received until Resin is stopped. Then the message is the following :

[2006-03-11 13:53:21] java.lang.NullPointerException
[2006-03-11 13:53:21] at com.caucho.ejb.xa.EjbTransactionManager.beginRequired(EjbTransactionManager.java:252)
[2006-03-11 13:53:21] at _ejb.AccesEJB.AccesBean__EJB$Local.setEndTime(AccesBean__EJB.java:392)
[2006-03-11 13:53:21] at com.codexam.wrappers.AccessWrapper.valueUnbound(Unknown Source)
[2006-03-11 13:53:21] at com.caucho.server.session.SessionImpl.notifyValueUnbound(SessionImpl.java:745)
[2006-03-11 13:53:21] at com.caucho.server.session.SessionImpl.unbind(SessionImpl.java:727)
[2006-03-11 13:53:21] at com.caucho.server.session.SessionImpl.invalidateLocal(SessionImpl.java:631)
[2006-03-11 13:53:21] at com.caucho.server.session.SessionImpl.removeEvent(SessionImpl.java:483)
[2006-03-11 13:53:21] at com.caucho.util.LruCache.remove(LruCache.java:469)
[2006-03-11 13:53:21] at com.caucho.server.session.SessionManager.close(SessionManager.java:1420)
[2006-03-11 13:53:21] at com.caucho.server.webapp.Application.destroy(Application.java:2394)
[2006-03-11 13:53:21] at com.caucho.server.deploy.DeployController.stopImpl(DeployController.java:669)
[2006-03-11 13:53:21] at com.caucho.server.deploy.AbstractDeployControllerStrategy.stop(AbstractDeployControllerStrategy.java:77)
[2006-03-11 13:53:21] at com.caucho.server.deploy.DeployController.stop(DeployController.java:491)
[2006-03-11 13:53:21] at com.caucho.server.deploy.DeployContainer.stop(DeployContainer.java:386)
[2006-03-11 13:53:21] at com.caucho.server.webapp.ApplicationContainer.stop(ApplicationContainer.java:1022)
[2006-03-11 13:53:21] at com.caucho.server.host.Host.stop(Host.java:478)
[2006-03-11 13:53:21] at com.caucho.server.host.Host.destroy(Host.java:495)
[2006-03-11 13:53:21] at com.caucho.server.deploy.DeployController.stopImpl(DeployController.java:669)
[2006-03-11 13:53:21] at com.caucho.server.deploy.AbstractDeployControllerStrategy.stop(AbstractDeployControllerStrategy.java:77)
[2006-03-11 13:53:21] at com.caucho.server.deploy.DeployController.stop(DeployController.java:491)
[2006-03-11 13:53:21] at com.caucho.server.deploy.DeployContainer.stop(DeployContainer.java:386)
[2006-03-11 13:53:21] at com.caucho.server.host.HostContainer.stop(HostContainer.java:478)
[2006-03-11 13:53:21] at com.caucho.server.resin.ServletServer.stop(ServletServer.java:1271)
[2006-03-11 13:53:21] at com.caucho.server.resin.ServletServer.destroy(ServletServer.java:1309)
[2006-03-11 13:53:21] at com.caucho.server.deploy.DeployController.stopImpl(DeployController.java:669)
[2006-03-11 13:53:21] at com.caucho.server.deploy.AbstractDeployControllerStrategy.stop(AbstractDeployControllerStrategy.java:77)
[2006-03-11 13:53:21] at com.caucho.server.deploy.DeployController.stop(DeployController.java:491)
[2006-03-11 13:53:21] at com.caucho.server.deploy.DeployController.destroy(DeployController.java:729)
[2006-03-11 13:53:21] at com.caucho.server.deploy.EnvironmentDeployController.destroy(EnvironmentDeployController.java:331)
[2006-03-11 13:53:21] at com.caucho.server.resin.ResinServer.destroy(ResinServer.java:548)
[2006-03-11 13:53:21] at com.caucho.server.resin.Resin$1.run(Resin.java:637)
[2006-03-11 13:53:21] Can't store session: com.caucho.ejb.EJBExceptionWrapper: java.lang.NullPointerException
[2006-03-11 13:53:21] com.caucho.ejb.EJBExceptionWrapper: java.lang.NullPointerException
[2006-03-11 13:53:21] at com.caucho.ejb.EJBExceptionWrapper.create(EJBExceptionWrapper.java:83)
[2006-03-11 13:53:21] at com.caucho.ejb.xa.EjbTransactionManager.beginRequired(EjbTransactionManager.java:306)
[2006-03-11 13:53:21] at _ejb.AccesEJB.AccesBean__EJB$Local.setEndTime(AccesBean__EJB.java:392)
[2006-03-11 13:53:21] at com.codexam.wrappers.AccessWrapper.valueUnbound(Unknown Source)
[2006-03-11 13:53:21] at com.caucho.server.session.SessionImpl.notifyValueUnbound(SessionImpl.java:745)
[2006-03-11 13:53:21] at com.caucho.server.session.SessionImpl.unbind(SessionImpl.java:727)
[2006-03-11 13:53:21] at com.caucho.server.session.SessionImpl.invalidateLocal(SessionImpl.java:631)
[2006-03-11 13:53:21] at com.caucho.server.session.SessionImpl.removeEvent(SessionImpl.java:483)
[2006-03-11 13:53:21] at com.caucho.util.LruCache.remove(LruCache.java:469)
[2006-03-11 13:53:21] at com.caucho.server.session.SessionManager.close(SessionManager.java:1420)
[2006-03-11 13:53:21] at com.caucho.server.webapp.Application.destroy(Application.java:2394)
[2006-03-11 13:53:21] at com.caucho.server.deploy.DeployController.stopImpl(DeployController.java:669)
[2006-03-11 13:53:21] at com.caucho.server.deploy.AbstractDeployControllerStrategy.stop(AbstractDeployControllerStrategy.java:77)
[2006-03-11 13:53:21] at com.caucho.server.deploy.DeployController.stop(DeployController.java:491)
[2006-03-11 13:53:21] at com.caucho.server.deploy.DeployContainer.stop(DeployContainer.java:386)
[2006-03-11 13:53:21] at com.caucho.server.webapp.ApplicationContainer.stop(ApplicationContainer.java:1022)
[2006-03-11 13:53:21] at com.caucho.server.host.Host.stop(Host.java:478)
[2006-03-11 13:53:21] at com.caucho.server.host.Host.destroy(Host.java:495)
[2006-03-11 13:53:21] at com.caucho.server.deploy.DeployController.stopImpl(DeployController.java:669)
[2006-03-11 13:53:21] at com.caucho.server.deploy.AbstractDeployControllerStrategy.stop(AbstractDeployControllerStrategy.java:77)
[2006-03-11 13:53:21] at com.caucho.server.deploy.DeployController.stop(DeployController.java:491)
[2006-03-11 13:53:21] at com.caucho.server.deploy.DeployContainer.stop(DeployContainer.java:386)
[2006-03-11 13:53:21] at com.caucho.server.host.HostContainer.stop(HostContainer.java:478)
[2006-03-11 13:53:21] at com.caucho.server.resin.ServletServer.stop(ServletServer.java:1271)
[2006-03-11 13:53:21] at com.caucho.server.resin.ServletServer.destroy(ServletServer.java:1309)
[2006-03-11 13:53:21] at com.caucho.server.deploy.DeployController.stopImpl(DeployController.java:669)
[2006-03-11 13:53:21] at com.caucho.server.deploy.AbstractDeployControllerStrategy.stop(AbstractDeployControllerStrategy.java:77)
[2006-03-11 13:53:21] at com.caucho.server.deploy.DeployController.stop(DeployController.java:491)
[2006-03-11 13:53:21] at com.caucho.server.deploy.DeployController.destroy(DeployController.java:729)
[2006-03-11 13:53:21] at com.caucho.server.deploy.EnvironmentDeployController.destroy(EnvironmentDeployController.java:331)
[2006-03-11 13:53:21] at com.caucho.server.resin.ResinServer.destroy(ResinServer.java:548)
[2006-03-11 13:53:21] at com.caucho.server.resin.Resin$1.run(Resin.java:637)
[2006-03-11 13:53:21] Caused by: java.lang.NullPointerException
[2006-03-11 13:53:21] at com.caucho.ejb.xa.EjbTransactionManager.beginRequired(EjbTransactionManager.java:252)
[2006-03-11 13:53:21] ... 30 more
[2006-03-11 13:53:21] resin-file: destroy
Additional Information MySQL version is 4.1.14-standard
Several version of MySQL Connector J have been tried with the same result.
The problem seems to be specific to MySQL 4.1 under Linux
It has been reproduced with MySQL 4.1.15-log under Linux
It could not be reproduced with MySQL 4.0
It could not be reproduced with MySQL 5 under Windows
Attached Files

- Relationships

- Notes
(0000935)
volga
03-11-06 06:05

I forgot to say that we have tested the exact same application with exact same lib and MySQL version under Resin 3.0.17 and the issue can't be reproduced.
 
(0000986)
ferg
03-02-06 11:09

server/1579
 

- Issue History
Date Modified Username Field Change
03-11-06 06:02 volga New Issue
03-11-06 06:05 volga Note Added: 0000935
03-02-06 11:09 ferg Note Added: 0000986
03-02-06 11:09 ferg Assigned To  => ferg
03-02-06 11:09 ferg Status new => closed
03-02-06 11:09 ferg Resolution open => fixed
03-02-06 11:09 ferg Fixed in Version  => 3.0.19


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
31 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker