Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000937 [Resin] major always 02-14-06 09:46 04-07-06 15:23
Reporter anonymous View Status public  
Assigned To ferg
Priority normal Resolution not fixable  
Status closed   Product Version 3.0.14
Summary 0000937: mod_caucho (in apache) passes decoded url to srun
Description mod_caucho with apache (1.3, 2.0, and 2.2) seems to decode all urls before passing them to the srun server. This is a problem in that our application is dependent on URLs that contain product names. These names contain many special characters. The ones that seem to be the most troublesome are "%", "?", and "\". For obvious reasons these characters need to be encoded on the URL until we parse the URL in our struts actions.
Additional Information try passing the following through a apache/mod_caucho configuration.
http://somewebsite/product/Womens%5CFootwear%5CDress_Casual%5CLoafer/ [^]
The srun version will show up in the resin access log as:
http://somewebsite/product/Womens\Footwear\Dress_Casual\Loafer/ [^]

Then do the same through the resin http server. The resin http server will not unencode the URL. Again, view the access log:
http://somewebsite/product/Womens%5CFootwear%5CDress_Casual%5CLoafer/ [^]

We are running on Redhat 9 (Alos tried on OS X, same results)
jdk 1.5
resin 3.0.14
apache 1.3 (I've tried on all three latest versions of apache)
Attached Files

- Relationships

- Notes
04-07-06 15:23

You will need to use Resin standalone in that case.

Because of Apache's mod_rewrite, Resin needs to use r->uri from Apache (not r->unparsed_uri). Changing to use r->unparsed_uri would break any use of mod_rewrite.

Using Resin standalone will avoid this issue. (Besides, standalone is faster and less complicated.)

- Issue History
Date Modified Username Field Change
02-14-06 09:46 anonymous New Issue
04-07-06 15:23 ferg Note Added: 0001054
04-07-06 15:23 ferg Assigned To  => ferg
04-07-06 15:23 ferg Status new => closed
04-07-06 15:23 ferg Resolution open => not fixable

Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
28 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker