Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000706 [Resin] minor always 01-05-06 11:08 01-02-06 16:18
Reporter ferg View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.0.17
Summary 0000706: alternate SESSIONID generation
Description (rep by Serge Knystautas)

The new Apache HTTPD 2.2 has load balancing and stickysession capability by building onto the mod_proxy capabilities, which I'm trying to take advantage of.

The problem is that their stickysession capabilities is heavily reliant on how Tomcat generates JSESSIONID. Instead of prepending the session ID with the srun index, they append a '.' and then the srun index (or route as they call it).

Would it be possible to have a setting to specify how JSESSIONID's are generated? It looks like the change would be isolated to com.caucho.server.session.SessionManager since that handles generating the session ID and determining whether this is in this session group.
Additional Information
Attached Files

- Relationships

- Notes
(0000822)
ferg
01-02-06 16:18

server/01l4
 

- Issue History
Date Modified Username Field Change
01-05-06 11:08 ferg New Issue
01-02-06 16:18 ferg Note Added: 0000822
01-02-06 16:18 ferg Assigned To  => ferg
01-02-06 16:18 ferg Status new => closed
01-02-06 16:18 ferg Resolution open => fixed
01-02-06 16:18 ferg Fixed in Version  => 3.0.18
01-02-06 16:18 ferg View Status @0@ => public


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
28 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker