Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006321 [Resin] minor always 01-02-20 14:24 02-04-20 02:31
Reporter nam View Status public  
Assigned To
Priority normal Resolution duplicate  
Status closed   Product Version 4.0.62
Summary 0006321: ClientDisconnectException after upgrading from RHEL6 to RHEL7
Description (rep by L. Kaminsky)

After migration of the application from RHEL6 to RHEL7, application became unstable with “ClientDisconnectException” happening even for one user.

[20-01-29 14:16:04.458] {resin-port-8080-32} com.caucho.vfs.ClientDisconnectException: Client disconnect fd=222 errno=32

                             at com.caucho.vfs.JniSocketImpl.writeNative(Native Method)

                             at com.caucho.vfs.JniSocketImpl.write(JniSocketImpl.java:502)

                             at com.caucho.vfs.JniStream.write(JniStream.java:153)

                             at com.caucho.vfs.WriteStream.nextBuffer(WriteStream.java:364)

                             at com.caucho.server.http.HttpResponseStream.writeNextBufferImpl(HttpResponseStream.java:166)

                             at com.caucho.server.http.ResponseStream.writeNextBuffer(ResponseStream.java:885)

                             at com.caucho.server.http.ResponseStream.flush(ResponseStream.java:589)

                             at com.caucho.server.http.HttpServletResponseImpl.flushBuffer(HttpServletResponseImpl.java:232)

                             at com.caucho.server.http.CauchoResponseWrapper.flushBuffer(CauchoResponseWrapper.java:143)

                             at javax.servlet.ServletResponseWrapper.flushBuffer(ServletResponseWrapper.java:189)

                             at com.caucho.server.http.ResponseWrapper.flushBuffer(ResponseWrapper.java:223)

                             at com.caucho.jsp.JspWriterAdapter.flush(JspWriterAdapter.java:247)

                             at org.apache.struts.taglib.tiles.InsertTag$InsertHandler.doEndTag(InsertTag.java:889)

                             at org.apache.struts.taglib.tiles.InsertTag.doEndTag(InsertTag.java:462)

                             at _jsp._web_22dinf._layouts._default._core._layout_22dmenu_22done_22dform__jsp._jspService(_layout_22dmenu_22done_22dform__jsp.java:180)

                             at _jsp._web_22dinf._layouts._default._core._layout_22dmenu_22done_22dform__jsp._jspService(_layout_22dmenu_22done_22dform__jsp.java:57)

                             at com.caucho.jsp.JavaPage.service(JavaPage.java:64)

                             at com.caucho.jsp.Page.pageservice(Page.java:557)

                             at com.caucho.server.dispatch.PageFilterChain.doFilter(PageFilterChain.java:194)

                             at com.caucho.server.webapp.DispatchFilterChain.doFilter(DispatchFilterChain.java:131)

                             at com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:304)

                             at com.caucho.server.webapp.RequestDispatcherImpl.forward(RequestDispatcherImpl.java:298)

                             at com.caucho.server.webapp.RequestDispatcherImpl.forward(RequestDispatcherImpl.java:116)

                             at org.apache.struts.action.RequestProcessor.doForward(RequestProcessor.java:1085)

                             at org.apache.struts.tiles.TilesRequestProcessor.doForward(TilesRequestProcessor.java:263)

                             at org.apache.struts.tiles.TilesRequestProcessor.processTilesDefinition(TilesRequestProcessor.java:239)

                             at org.apache.struts.tiles.TilesRequestProcessor.processForwardConfig(TilesRequestProcessor.java:302)

                             at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:241)

                             at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)

                             at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)

                             at javax.servlet.http.HttpServlet.service(HttpServlet.java:120)

                             at javax.servlet.http.HttpServlet.service(HttpServlet.java:97)

                             at com.caucho.server.dispatch.ServletFilterChain.doFilter(ServletFilterChain.java:109)

                             at cab.servlet.filter.CrossScriptingFilter.doFilter(CrossScriptingFilter.java:33)

                             at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:89)

                             at cab.servlet.filter.XssFilter.doFilter(XssFilter.java:36)

                             at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:89)

                             at com.caucho.server.webapp.WebAppFilterChain.doFilter(WebAppFilterChain.java:156)

                             at com.caucho.server.webapp.AccessLogFilterChain.doFilter(AccessLogFilterChain.java:95)

                             at com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:304)

                             at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:843)

                             at com.caucho.network.listen.TcpSocketLink.dispatchRequest(TcpSocketLink.java:1370)

                             at com.caucho.network.listen.TcpSocketLink.handleRequest(TcpSocketLink.java:1326)

                             at com.caucho.network.listen.TcpSocketLink.handleRequestsImpl(TcpSocketLink.java:1310)

                             at com.caucho.network.listen.TcpSocketLink.handleRequests(TcpSocketLink.java:1218)

                             at com.caucho.network.listen.TcpSocketLink.handleAcceptTaskImpl(TcpSocketLink.java:1014)

                             at com.caucho.network.listen.ConnectionTask.runThread(ConnectionTask.java:117)

                             at com.caucho.network.listen.ConnectionTask.run(ConnectionTask.java:93)

                             at com.caucho.network.listen.SocketLinkThreadLauncher.handleTasks(SocketLinkThreadLauncher.java:175)

                             at com.caucho.network.listen.TcpSocketAcceptThread.run(TcpSocketAcceptThread.java:61)

                             at com.caucho.env.thread2.ResinThread2.runTasks(ResinThread2.java:173)

                             at com.caucho.env.thread2.ResinThread2.run(ResinThread2.java:118)

                       

[20-01-29 14:16:04.458] {resin-port-8080-32} Http[app-0, 21] close stream

[20-01-29 14:16:04.458] {resin-port-8080-32} Http[app-0, 21] flush()

 

 

 

[20-01-29 14:32:18.163] {resin-port-8080-33} com.caucho.vfs.ClientDisconnectException: Client disconnect fd=158 errno=32

 

 

[20-01-29 14:37:54.500] {resin-port-8080-37} com.caucho.vfs.ClientDisconnectException: Client disconnect fd=146 errno=32

                      

                             at com.caucho.vfs.JniSocketImpl.writeNative(Native Method)

                             at com.caucho.vfs.JniSocketImpl.write(JniSocketImpl.java:502)

                             at com.caucho.vfs.JniStream.write(JniStream.java:153)

                             at com.caucho.vfs.WriteStream.nextBuffer(WriteStream.java:364)

                             at com.caucho.server.http.HttpResponseStream.writeNextBufferImpl(HttpResponseStream.java:166)

                             at com.caucho.server.http.ResponseStream.writeNextBuffer(ResponseStream.java:885)

                             at com.caucho.server.http.ResponseStream.flush(ResponseStream.java:589)

 

 

[20-01-29 14:37:54.500] {resin-port-8080-37} Http[app-0, 1] close stream

[20-01-29 14:37:54.500] {resin-port-8080-37} Http[app-0, 1] flush()

[20-01-29 14:37:54.500] {resin-port-8080-37} Dispatch '/WEB-INF/layouts/default/core/footer.jsp' to DispatchFilterChain[PageFilterChain[JspServlet[WebApp[production/webapp/default/itasprod]]]]

[20-01-29 14:37:54.501] {resin-port-8080-37} Dispatch '/WEB-INF/layouts/default/core/debug.jsp' to DispatchFilterChain[PageFilterChain[JspServlet[WebApp[production/webapp/default/itasprod]]]]

[20-01-29 14:37:54.501] {resin-port-8080-37} Dispatch '/WEB-INF/layouts/default/core/empty.jsp' to DispatchFilterChain[PageFilterChain[JspServlet[WebApp[production/webapp/default/itasprod]]]]

[20-01-29 14:37:54.501] {resin-port-8080-37} TcpSocketLink[id=1,app-0] closing connection TcpSocketLink[id=http://*:8080-1,http://*:8080,CLOSED], [^] total=12

 


 
Additional Information
Attached Files

- Relationships

- Notes
(0006936)
nam
02-04-20 02:31

Duplicate of 0006319.
 

- Issue History
Date Modified Username Field Change
01-02-20 14:24 nam New Issue
02-04-20 02:31 nam Note Added: 0006936
02-04-20 02:31 nam Status new => closed
02-04-20 02:31 nam Resolution open => duplicate


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
28 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker