Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005942 [Resin] minor always 08-03-15 04:05 06-27-16 11:39
Reporter bjornolsson View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 4.0.44
Summary 0005942: Posted HTML input names with non-ASCII characters are interpreted wrong
Description When posting the form below to a resin server, the name on the server becomes testparam¤test1. It seems to be caused by reading the input byte by byte.

<html>
  <head>
    <meta http-equiv="Content-Type" content="text/html;charset=utf-8">
  </head>
  <body>
    <form enctype="multipart/form-data" action="[som resin server]" method="post">
      <input name="testparam¤test" id="testparam¤test" type="text" value="Test">
      <input type="submit" value="Submit">
    </form>
  </body>
</html>

Regards,
Björn
Additional Information
Attached Files

- Relationships

- Notes
(0006680)
ebo
03-07-16 10:19

I noticed the same issue. Actually when removing enctype="multipart/form-data" it works fine.
 
(0006705)
ferg
06-27-16 11:39

server/1670
 

- Issue History
Date Modified Username Field Change
08-03-15 04:05 bjornolsson New Issue
03-07-16 10:19 ebo Note Added: 0006680
06-27-16 11:39 ferg Note Added: 0006705
06-27-16 11:39 ferg Assigned To  => ferg
06-27-16 11:39 ferg Status new => closed
06-27-16 11:39 ferg Resolution open => fixed
06-27-16 11:39 ferg Fixed in Version  => 4.0.49


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
32 total queries executed.
28 unique queries executed.
Powered by Mantis Bugtracker