Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005870 [Resin] minor always 03-24-15 16:30 03-02-15 17:15
Reporter nam View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.1.14
Summary 0005870: mod_caucho: configure script needs to add -m64 to LD_SHLIB on solaris
Description (rep by N. Sundararaman)

Resin 3.1.14

Bad Makefile:
-------------------------------------------------------
.SUFFIXES: .o .lo .so

CC=gcc
CP=/bin/cp
CFLAGS=-g -O2 -DPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -D__SOLARIS__ -DHAS_JVMTI
CFLAGS_SHLIB=-fPIC
EGREP=/usr/sfw/bin/ggrep -E
LD=/usr/ccs/bin/ld
LIBTOOL=EGREP="/usr/sfw/bin/ggrep -E" /tmp/nsn/resin-pro-3.1.13/libtool --silent --tag=CXX
LD_SHLIB=/usr/ccs/bin/ld
LIBS_SHLIB=
LDFLAGS=
LDFLAGS_SHLIB=-G -fPIC
APACHE_INC=-I/global/camin-http/apache-2.2.29_64/include
apache_conf=/usr/apache2/conf
apache_dir=
apache_libexec=/usr/apache2/libexec
resin_home=/tmp/nsn/resin-pro-3.1.13
INCLUDES = $(APACHE_INC) -DRESIN_HOME=\"$(resin_home)\" -I../common
C=../common
COMMON_OBJ=$C/stream.lo $C/config.lo $C/memory.lo
OBJ_PICS=mod_caucho.lo $(COMMON_OBJ)

all : mod_caucho.la

#mod_caucho.so : mod_caucho.la
# mv mod_caucho.la mod_caucho.so

mod_caucho.la : $(OBJ_PICS)
    $(LIBTOOL) --mode=link $(LD_SHLIB) -module -o $@ -avoid-version -rpath $(apache_libexec) $(OBJ_PICS) $(LIBS_SHLIB)

.c.lo :
    $(LIBTOOL) --mode=compile $(CC) -o $@ -c $(INCLUDES) $(CFLAGS) $<

.c.o :
    $(CC) -c $(INCLUDES) $(CFLAGS) $<

install : mod_caucho.la
    $(LIBTOOL) --mode=install $(CP) mod_caucho.la $(apache_libexec)
    - rm -f $(apache_libexec)/mod_caucho.la
    - rm -f $(apache_libexec)/mod_caucho.a
    sh install.sh -conf $(apache_conf) -libexec $(apache_libexec) \
       -resin_home $(resin_home)

clean :
    - rm -r *.o *.lo *.la *.so .libs

$(OBJ_PICS) : Makefile ../common/cse.h
mod_caucho.lo : Makefile ../common/cse.h

Additional Information
Attached Files

- Relationships

- Notes
(0006593)
nam
03-24-15 16:33

checking build system type... sparc-sun-solaris2.10
checking host system type... sparc-sun-solaris2.10
checking target system type... sparc-sun-solaris2.10
checking for a BSD-compatible install... automake/install-sh -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... automake/install-sh -c -d
checking for gawk... no
checking for mawk... no
checking for nawk... nawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... none
checking for a sed that does not truncate output... /usr/bin/sed
checking for grep that handles long lines and -e... /usr/sfw/bin/ggrep
checking for egrep... /usr/sfw/bin/ggrep -E
checking for fgrep... /usr/sfw/bin/ggrep -F
checking how to print strings... printf
checking for ld used by gcc... /usr/ccs/bin/ld
checking if the linker (/usr/ccs/bin/ld) is GNU ld... no
checking for egrep... (cached) /usr/sfw/bin/ggrep -E
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking sys/poll.h usability... yes
checking sys/poll.h presence... yes
checking for sys/poll.h... yes
checking sys/epoll.h usability... no
checking sys/epoll.h presence... no
checking for sys/epoll.h... no
checking for BSD- or MS-compatible name lister (nm)... /usr/ccs/bin/nm -p
checking the name lister (/usr/ccs/bin/nm -p) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 786240
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking how to convert sparc-sun-solaris2.10 file names to sparc-sun-solaris2.10 format... func_convert_file_noop
checking how to convert sparc-sun-solaris2.10 file names to toolchain format... func_convert_file_noop
checking for /usr/ccs/bin/ld option to reload object files... -r
checking for objdump... no
checking how to recognize dependent libraries... pass_all
checking for dlltool... no
checking how to associate runtime and link libraries... printf %s\n
checking for ar... ar
checking for archiver @FILE support... no
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/ccs/bin/nm -p output from gcc object... ok
checking for sysroot... no
checking for mt... mt
checking if mt is a manifest tool... no
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... no
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/ccs/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... yes
checking dynamic linker characteristics... solaris2.10 ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... no
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking for JAVA_HOME... /usr/java
checking if Java is 64-bit... yes
Using Apache 2.0 configuration /global/camin-http/apache-2.2.29_64/conf/httpd.conf
checking for JNI in /usr/java/include/solaris ... found
Using JVMTI for class reloading
Openssl library was not found
configure: creating ./config.status
config.status: creating Makefile
config.status: creating modules/c/src/Makefile
config.status: creating modules/c/src/common/Makefile
config.status: creating modules/c/src/apache1/Makefile
config.status: creating modules/c/src/apache2/Makefile
config.status: creating modules/c/src/resin_os/Makefile
config.status: creating contrib/init.resin
config.status: executing depfiles commands
config.status: executing libtool commands
configure: creating ./config.status
config.status: creating Makefile
config.status: creating modules/c/src/Makefile
config.status: creating modules/c/src/common/Makefile
config.status: creating modules/c/src/apache1/Makefile
config.status: creating modules/c/src/apache2/Makefile
config.status: creating modules/c/src/resin_os/Makefile
config.status: creating contrib/init.resin
config.status: creating modules/c/src/resin/Makefile
config.status: creating modules/c/src/resinssl/Makefile
config.status: executing depfiles commands
config.status: executing libtool commands
 
(0006607)
ferg
03-02-15 17:15

Updated in source, but since 3.1.x is frozen, there is not a planned release with the change.
 

- Issue History
Date Modified Username Field Change
03-24-15 16:30 nam New Issue
03-24-15 16:33 nam Note Added: 0006593
03-02-15 17:15 ferg Note Added: 0006607
03-02-15 17:15 ferg Assigned To  => ferg
03-02-15 17:15 ferg Status new => closed
03-02-15 17:15 ferg Resolution open => fixed
03-02-15 17:15 ferg Fixed in Version  => 3.1.14


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
31 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker