Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005803 [Resin] minor always 09-24-14 15:56 11-03-14 11:29
Reporter nam View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0005803: LogDatabase query exception when log_data.db is very large
Description (rep by R. Murayama)

Some of our customers have encountered your Resinís log data file, called, log_data.db, glows very large.

If the file glows over 2GB, it seems Resin server would fail to start-up due to java.IOException as below.

 
Resin Professional 4.0.35 (built Tue, 12 Feb 2013 10:07:47 PST)


-rw-rw---- 1 root imail 7616856064 Sep 24 13:46 log_data.db
 

l Java.IOException Error

If the file glows over 2GB, resin server would fail to launch due to java.io.IOException as below.

20140811 164554421+0900 webmail02 webedge - - 10 com.caucho.config.ConfigRuntimeException: com.caucho.util.SQLExceptionWrapper: java.io.IOException: '/imail/webedge/httpd/resin-webedge/resin-data/a/log/log_data.db' unknown error (errno=75).
at com.caucho.config.ConfigException.create(ConfigException.java:168)
at com.caucho.env.log.LogDatabase.<init>(LogDatabase.java:61)
at com.caucho.env.log.ProLogSystem.start(ProLogSystem.java:398)
at com.caucho.env.service.ResinSystem.startServices(ResinSystem.java:544)
at com.caucho.env.service.ResinSystem.start(ResinSystem.java:511)
at com.caucho.server.resin.Resin.start(Resin.java:849)
at com.caucho.server.resin.Resin.initMain(Resin.java:981)
at com.caucho.server.resin.Resin.main(Resin.java:1437)
Caused by: com.caucho.util.SQLExceptionWrapper: java.io.IOException: '/imail/webedge/httpd/resin-webedge/resin-data/a/log/log_data.db' unknown error (errno=75).
at com.caucho.db.sql.CreateQuery.execute(CreateQuery.java:67)
at com.caucho.db.jdbc.StatementImpl.executeUpdate(StatementImpl.java:200)
at com.caucho.db.jdbc.StatementImpl.executeUpdate(StatementImpl.java:151)
at com.caucho.env.log.LogDatabase.createDatabases(LogDatabase.java:161)
at com.caucho.env.log.LogDatabase.<init>(LogDatabase.java:54)
Caused by: java.io.IOException: '/imail/webedge/httpd/resin-webedge/resin-data/a/log/log_data.db' unknown error (errno=75).
at com.caucho.vfs.JniFileStream.openWrite(JniFileStream.java:105)
at com.caucho.vfs.JniFilePathImpl.openWriteImpl(JniFilePathImpl.java:420)
at com.caucho.vfs.Path.openWrite(Path.java:1162)
at com.caucho.db.block.BlockReadWrite.create(BlockReadWrite.java:124)
at com.caucho.db.block.BlockStore.create(BlockStore.java:463)
at com.caucho.db.table.Table.create(Table.java:369)
at com.caucho.db.table.TableFactory.create(TableFactory.java:394)
at com.caucho.db.sql.CreateQuery.execute(CreateQuery.java:65)
Additional Information
Attached Files

- Relationships

- Notes
(0006541)
ferg
11-03-14 11:29

Changed create() to remove the old file first.
 

- Issue History
Date Modified Username Field Change
09-24-14 15:56 nam New Issue
11-03-14 11:29 ferg Note Added: 0006541
11-03-14 11:29 ferg Assigned To  => ferg
11-03-14 11:29 ferg Status new => closed
11-03-14 11:29 ferg Resolution open => fixed
11-03-14 11:29 ferg Fixed in Version  => 4.0.42


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker