Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005776 [Resin] minor always 07-15-14 10:11 08-07-14 14:25
Reporter alex View Status public  
Assigned To ferg
Priority normal Resolution open  
Status closed   Product Version 4.0.40
Summary 0005776: servlet-async: java.lang.IllegalStateException: The servlet '/error1' at '/error1' does not support async
Description Exception with legal servlet.

I cleared resin-data and redeployed the app, but I'm still able to reproduce the issue.
I used the following steps to reproduce:

./bin/ stop
rm -rf resin-data/app-0
rm -rf webapps/servlet3-async*
./bin/ start
cp ~/servlet3-async.war webapps

curl -D - 'http://localhost:8080/servlet3-async/error2?fail=true' [^]
curl -D - http://localhost:8080/servlet3-async/error1 [^]

I'm using war deployment.
Additional Information java.lang.IllegalStateException: The servlet '/error1' at '/error1' does
not support async because the servlet or one of the filters does not support
asynchronous mode. The servlet should be annotated with a @WebServlet(asyncSupported=true)
annotation or have a <async-supported> tag in the web.xml.
    at com.caucho.server.http.HttpServletRequestImpl.startAsync(
    at com.caucho.server.http.HttpServletRequestImpl.startAsync(
    at fi.markoa.servlet3.AsyncErrorServlet1.doGet(
    at javax.servlet.http.HttpServlet.service(
    at javax.servlet.http.HttpServlet.service(
    at com.caucho.server.dispatch.ServletFilterChain.doFilter(
    at com.caucho.server.webapp.WebAppFilterChain.doFilter(
    at com.caucho.server.webapp.AccessLogFilterChain.doFilter(
    at com.caucho.server.dispatch.ServletInvocation.service(
    at com.caucho.server.http.HttpRequest.handleRequest(
    at com.caucho.env.thread2.ResinThread2.runTasks(
Attached Files

- Relationships

- Notes
07-15-14 11:50

source code for servlet3-async.war can be found here: [^]
08-07-14 14:25


- Issue History
Date Modified Username Field Change
07-15-14 10:11 alex New Issue
07-15-14 10:11 alex version  => 4.0.40
07-15-14 10:11 alex Description Updated
07-15-14 11:42 marko_asplund Issue Monitored: marko_asplund
07-15-14 11:50 marko_asplund Note Added: 0006462
08-07-14 14:25 ferg Note Added: 0006466
08-07-14 14:25 ferg Assigned To  => ferg
08-07-14 14:25 ferg Status new => closed
08-07-14 14:25 ferg Fixed in Version  => 4.0.41

Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
35 total queries executed.
29 unique queries executed.
Powered by Mantis Bugtracker