Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005741 [Baratine] minor always 05-01-14 13:52 06-10-14 17:08
Reporter nam View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0005741: hessian exception when calling ResourceManager.findOne() from ClientHamp
Description baratine/7623

test case is calling findOne(String), but com.caucho.amp.hamp.InHamp using the findOne(Result,String) method instead

Caused by: io.baratine.core.ServiceExceptionExecution: java.lang.UnsupportedOperationException: class com.caucho.hessian.io.BasicDeserializer[10], length=0
    at com.caucho.amp.message.QueryRefFuture.get(QueryRefFuture.java:95)
    at com.caucho.amp.message.QueryWithFutureMessageBase.offerAndGet(QueryWithFutureMessageBase.java:74)
    at io.baratine.core.ResourceManager__AmpProxyChild.findOne(Unknown Source)
    at com.caucho.quercus.env.JavaInvoker.callMethod(JavaInvoker.java:858)
    ... 22 more
Caused by: java.lang.UnsupportedOperationException: class com.caucho.hessian.io.BasicDeserializer[10], length=0
    at com.caucho.hessian.io.BasicDeserializer.readLengthList(BasicDeserializer.java:605)
    at com.caucho.hessian.io.Hessian2Input.readObject(Hessian2Input.java:1871)
    at com.caucho.amp.hamp.InHamp.readArgs(InHamp.java:397)
    at com.caucho.amp.hamp.InHamp.readMessage(InHamp.java:248)
    at com.caucho.amp.jamp.InHampWebSocket.onMessage(InHampWebSocket.java:71)
    at com.caucho.amp.jamp.InHampWebSocket.onMessage(InHampWebSocket.java:45)
    at com.caucho.websocket.plain.ReadInputStreamPlain.onRead(ReadInputStreamPlain.java:58)
    at com.caucho.websocket.plain.EndpointReaderPlain.readFrame(EndpointReaderPlain.java:140)
    at com.caucho.websocket.plain.EndpointReaderPlain.onRead(EndpointReaderPlain.java:110)
    at com.caucho.websocket.server.RequestWebSocketServer.handleRequest(RequestWebSocketServer.java:165)
    at com.caucho.http.protocol.RequestProtocolHttp.handleRequest(RequestProtocolHttp.java:192)
    at com.caucho.network.listen.ConnectionTcp.dispatchRequest(ConnectionTcp.java:1053)
    at com.caucho.network.listen.ConnectionTcp.doRequests(ConnectionTcp.java:901)
    at com.caucho.network.listen.TaskConnection.run(TaskConnection.java:92)
    at com.caucho.amp.queue.QueueServiceSpawn$RunnableQueueServiceSpawn.run(QueueServiceSpawn.java:92)
    at com.caucho.amp.thread.ThreadAmp.runTasks(ThreadAmp.java:191)
    at com.caucho.amp.thread.ThreadAmp.run(ThreadAmp.java:158)
Additional Information
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
05-01-14 13:52 nam New Issue
06-10-14 17:08 ferg Assigned To  => ferg
06-10-14 17:08 ferg Status new => closed
06-10-14 17:08 ferg Resolution open => fixed
06-10-14 17:08 ferg Fixed in Version  => 0.8.3


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
27 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker