Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005554 [Resin] minor always 10-14-13 07:56 09-08-14 17:50
Reporter cowan View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 4.0.37
Summary 0005554: Startup always reports unclean shutdown
Description Resin always reports "validating indexes due to unclean shutdown", even when resin is shutdown normally using "resinctl stop" or "resinctl shutdown". This was verified on an unmodified Resin Pro 4.0.35 and 4.0.37 install with no changes to config other than adding a license.

[13-10-14 10:53:57.197] {resin-shutdown} ProServer[id=app-0,cluster=app] stopping
[13-10-14 10:53:57.199] {resin-shutdown} Host[production/host/default] stopping
[13-10-14 10:53:57.199] {resin-shutdown} WebApp[production/webapp/default/resin-doc] stopping
[13-10-14 10:53:57.425] {resin-shutdown} WebApp[production/webapp/default/ROOT] stopping
[13-10-14 10:53:57.432] {resin-shutdown} WebApp[production/webapp/default/resin-admin] stopping
[13-10-14 10:53:57.479] {resin-shutdown} ClusterServer[id=app-0,127.0.0.1:6800] notify-heartbeat-stop

Shutdown Resin reason: OK

[13-10-14 10:53:57.505] {resin-shutdown} Shutdown Resin reason: OK
Resin Professional 4.0.37 (built Thu, 05 Sep 2013 08:05:15 PDT)
Copyright(c) 1998-2012 Caucho Technology. All rights reserved.

  current.license -- 1 Resin server Caucho

[13-10-14 10:54:21.512] {main} current.license -- 1 Resin server Caucho
                       
Starting Resin Professional on Mon, 14 Oct 2013 10:54:19 -0400 (EDT)

[13-10-14 10:54:22.071] {main} Proxy Cache disk-size=1024M memory-size=16M
[13-10-14 10:54:22.623] {main}
[13-10-14 10:54:22.623] {main} Resin Professional 4.0.37 (built Thu, 05 Sep 2013 08:05:15 PDT)
[13-10-14 10:54:22.624] {main}
[13-10-14 10:54:22.624] {main} Mac OS X 10.8.5 x86_64
[13-10-14 10:54:22.624] {main} Java(TM) SE Runtime Environment 1.7.0_09-b05, UTF-8, en
[13-10-14 10:54:22.624] {main} Java HotSpot(TM) 64-Bit Server VM 23.5-b02, 64, mixed mode, Oracle Corporation
[13-10-14 10:54:22.624] {main}
[13-10-14 10:54:22.624] {main} user.name = paul
[13-10-14 10:54:23.253] {main} Table[stat_name:3] validating indexes due to unclean shutdown.
[13-10-14 10:54:23.276] {main} Table[stat_data:4] validating indexes due to unclean shutdown.
[13-10-14 10:54:25.404] {main}
[13-10-14 10:54:25.413] {main} server listening to localhost:6800
[13-10-14 10:54:25.420] {main}
[13-10-14 10:54:25.434] {main} Table[mnode:5] validating indexes due to unclean shutdown.
[13-10-14 10:54:25.459] {main} Table[data:6] validating indexes due to unclean shutdown.
[13-10-14 10:54:25.707] {main}
[13-10-14 10:54:25.707] {main} resin.home = /Users/paul/resin-pro-4.0.37/
[13-10-14 10:54:25.708] {main} resin.root = /Users/paul/resin-pro-4.0.37
[13-10-14 10:54:25.708] {main} resin.conf = /Users/paul/resin-pro-4.0.37/conf/resin.xml
[13-10-14 10:54:25.708] {main}
[13-10-14 10:54:25.709] {main} server = 127.0.0.1:6800 (app:app-0)
[13-10-14 10:54:25.709] {main} stage = production
[13-10-14 10:54:26.242] {resin-25} WebApp[production/webapp/default/resin-admin] active
[13-10-14 10:54:26.287] {resin-30} WebApp[production/webapp/default/ROOT] active
[13-10-14 10:54:27.576] {resin-52} WebApp[production/webapp/default/resin-doc] active
[13-10-14 10:54:27.581] {main} Host[production/host/default] active
[13-10-14 10:54:27.582] {main} ProServer[id=app-0,cluster=app] active
[13-10-14 10:54:27.584] {main} JNI: file, async keepalive (max=9984), socket
[13-10-14 10:54:27.584] {main}
[13-10-14 10:54:27.586] {main}
[13-10-14 10:54:27.588] {main} http listening to *:8080
[13-10-14 10:54:27.590] {main}
[13-10-14 10:54:27.684] {main} ProResin[id=app-0] started in 8063ms
[13-10-14 10:54:27.685] {resin-19} DumpJmx[] OK: JMX dump scheduled with a 60000 ms delay
Additional Information Rep by T. Pohl
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
10-14-13 07:56 cowan New Issue
09-08-14 17:50 ferg Assigned To  => ferg
09-08-14 17:50 ferg Status new => closed
09-08-14 17:50 ferg Resolution open => fixed
09-08-14 17:50 ferg Fixed in Version  => 4.0.40


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
27 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker