Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005543 [Resin] minor always 10-04-13 09:26 11-06-14 15:13
Reporter ferg View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 4.0.37
Summary 0005543: multipart-form with forwards
Description (rep by Shinomiya Nobuaki)

Part 1
1. When I run "HttpServletRequest#getPart" in a Servlet using
"getNamedDispatcher" and "forward", the following type of error occurs.

javax.servlet.ServletException: multipart-form is disabled; check
@MultipartConfig annotation on 'resin-file'.

I encountered this problem in the following environment:
* Windows 7 64-bit
* Resin Pro 4.0.37
* The servlet is configured with "multipart-config".

Here are procedures how to reproduce the error.
Please see the attached ZIP file.
This is including a war file ("multipart-
async/multipart/resin_multipartconfig_test.war") and those sorce codes.

1. Deploying the war file named "resin_multipartconfig_test.war" at Resin Pro 4.0.37.
2. Accessing the web page at "http://localhost:8080/resin_multipartconfig_test/upload". [^]
3. Push a button named "choose files", and then push a button named "submit" in case3.

When I used "getRequestDispatcher" instead of "getNamedDispatcher",
this problem did not occured. (You can confirm this fact in Case2.)
When I tried the same way using jetty9 , this problem did not occured at all.
On the other hand, when I also tried the same way using GlassFish4 ,
this problem did occured in both cases using "getRequestDispatcher" and "getNamedDispatcher".

Q1. Is this a bug of Resin?

Additional Information
Attached Files

- Relationships

- Notes
11-06-14 15:13


- Issue History
Date Modified Username Field Change
10-04-13 09:26 ferg New Issue
10-04-13 09:34 yanonaoki Issue Monitored: yanonaoki
11-06-14 15:13 ferg Note Added: 0006556
11-06-14 15:13 ferg Assigned To  => ferg
11-06-14 15:13 ferg Status new => closed
11-06-14 15:13 ferg Resolution open => fixed
11-06-14 15:13 ferg Fixed in Version  => 4.0.42

Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
30 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker