Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005522 [Resin] crash always 09-08-13 06:25 09-23-13 11:33
Reporter arjan_tijms View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 4.0.36
Summary 0005522: Generic producer method doesn't work with CanDI/Resin
Description When using a generic producer method with e.g. the following signature:

    public <V> ParamValue<V> produce(InjectionPoint injectionPoint)

Resin throws an exception with the following text:

 {resin-port-8080-43} classpath:META-INF/caucho/app-default.xml:55: javax.enterprise.inject.InjectionException: 'public org.omnifaces.cdi.param.ParamValue org.omnifaces.cdi.param.RequestParameterProducer.produce(javax.enterprise.inject.spi.InjectionPoint)' is an invalid @Produces method because it returns a generic type class org.omnifaces.cdi.param.ParamValue<produce_T_0>
                       53: default="true"/>
                       55: <resin:if test="${! quercus_disable}">
                       56: <servlet-mapping url-pattern="*.php"
                       57: servlet-name="resin-php"

Although the CDI 1.0 spec doesn't require this to work, it's not forbidden either. Weld 1.x/2.x and OpenWebBeans 1.1.x/1.2.x do support this. A snapshot of OpenWebBeans 1.2.1 didn't support this anymore (following CDI 1.1 discussions), but after some further discussion decided that it should indeed be supported.

See also [^]
Additional Information
Attached Files

- Relationships

- Notes
09-23-13 11:33


Note: this validation was required by the CDI TCK. It's not actually question of supporting; it's just removing a validation check that was required by TCK.

- Issue History
Date Modified Username Field Change
09-08-13 06:25 arjan_tijms New Issue
09-23-13 11:33 ferg Note Added: 0006325
09-23-13 11:33 ferg Assigned To  => ferg
09-23-13 11:33 ferg Status new => closed
09-23-13 11:33 ferg Resolution open => fixed
09-23-13 11:33 ferg Fixed in Version  => 4.0.38

Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker