Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005500 [Resin] minor always 08-21-13 08:34 10-04-13 10:17
Reporter cowan View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 4.0.36
Summary 0005500: Protect against OOM in watchdog
Description An out-of-memory can occur in the Watchdog, resulting in Watchdog shutdown.

[2013/08/15 18:46:23.138] {resin-1950} Watchdog received warning from Resin[app-0,pid=10636]:
                                         Shutdown: Resin exiting because of failed thread
java.lang.OutOfMemoryError: unable to create new native thread
        at java.lang.Thread.start0(Native Method)
        at java.lang.Thread.start(Thread.java:691)
        at com.caucho.env.thread2.ThreadLauncher2.launchChildThread(ThreadLauncher2.java:96)
        at com.caucho.env.thread2.AbstractThreadLauncher2.startConnection(AbstractThreadLauncher2.java:546)
        at com.caucho.env.thread2.AbstractThreadLauncher2.runTask(AbstractThreadLauncher2.java:645)
        at com.caucho.env.thread2.AbstractTaskWorker2.run(AbstractTaskWorker2.java:240)
        at java.lang.Thread.run(Thread.java:722)
WarningService: Shutdown: Resin exiting because of failed thread
[2013/08/15 18:46:23.151] {ThreadLauncher2[ThreadPool[system]]-1} WarningService: Shutdown: Resin exiting because of failed thread
[2013/08/15 18:46:23.182] {resin-shutdown} ProServer[id=default,cluster=watchdog] stopping
[2013/08/15 18:46:23.187] {resin-shutdown} Host[production/host/admin.resin] stopping
[2013/08/15 18:46:23.188] {resin-shutdown} WebApp[production/webapp/admin.resin/ROOT] stopping

Shutdown Resin reason: THREAD

[2013/08/15 18:46:23.207] {resin-shutdown} Shutdown Resin reason: THREAD
Additional Information Rep by K. Hosein
Attached Files

- Relationships

- Notes
(0006332)
ferg
10-04-13 10:17

Increased idle min/max and timeout to minimize the need for thread spawning in the watchdog.
 

- Issue History
Date Modified Username Field Change
08-21-13 08:34 cowan New Issue
08-01-13 15:04 kjh Issue Monitored: kjh
10-04-13 10:17 ferg Note Added: 0006332
10-04-13 10:17 ferg Assigned To  => ferg
10-04-13 10:17 ferg Status new => closed
10-04-13 10:17 ferg Resolution open => fixed
10-04-13 10:17 ferg Fixed in Version  => 4.0.38


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
31 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker