Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005469 [Resin] minor always 06-19-13 17:01 07-03-13 14:29
Reporter rickHigh View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0005469: Resin 7 Writing and then trying to read what you wrote
Description I have service code that looks like this:

    public void save() {
        System.out.println("SAVE CALLED");

        System.out.printf("write tasks %s \n", manager.tasks());

        store.store("tasks", manager.tasks());

        System.out.printf("write owners %s \n", manager.owners());

        store.store("ownerToTask", manager.owners());
        System.out.println("SAVE DONE");

    }

Based on the Resin log this is getting called.

I have read code that looks like this:

public void read() {
        System.out.println("READ CALLED");

        MakaiFuture<Object> future = new MakaiFuture<>();

        store.load("tasks", future); ///////// LOOK HERE

        Set<Task> tasks = (Set<Task>) future.get();
        System.out.printf("read tasks %s \n", tasks);

        store.load("ownerToTask", future); ///////// LOOK HERE

        Map<TaskOwner, Set<Task>> owners = (Map<TaskOwner, Set<Task>>) future.get();
        System.out.printf("read owners %s \n", owners);


    }


Here are the logs:
SAVE CALLED

write tasks [Task{timestamp=1371683602658, objectId='task2-8654663153036335188-1371683602658127000-1', name='task2', description='NULL', owner=Group{people=[], ... SNIP

write owners {}

SAVE DONE


READ CALLED

read tasks null

read owners {}

tasks comes back null. I wrote a Set, but I got nothing. This could be a serialization issue but I would expect an error message.

there is no indication in the log why saving owners worked but reading did not.
Additional Information
Attached Files

- Relationships

- Notes
(0006298)
ferg
07-03-13 14:29

makai/7042
 

- Issue History
Date Modified Username Field Change
06-19-13 17:01 rickHigh New Issue
07-03-13 14:29 ferg Note Added: 0006298
07-03-13 14:29 ferg Assigned To  => ferg
07-03-13 14:29 ferg Status new => closed
07-03-13 14:29 ferg Resolution open => fixed
07-03-13 14:29 ferg Fixed in Version  => 7.0.0
07-03-13 14:29 ferg Description Updated


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
30 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker