Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005392 [Resin] tweak always 03-12-13 10:39 05-02-13 11:55
Reporter alex View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 4.0.35
Summary 0005392: com.caucho.vfs.ClientDisconnectException: SocketStream[null]:java.net.SocketException: Connection reset by peer: socket write er
Description Exception needs to show receiving end of the connection


[13-03-10 08:38:51.339] {resin-33} com.caucho.bam.BamException: com.caucho.vfs.ClientDisconnectException: SocketStream[null]:java.net.SocketException: Connection reset by peer: socket write error
                           at com.caucho.network.balance.ClientSocket.switchToHmtp(ClientSocket.java:232)
                           at com.caucho.cloud.bam.HmtpStream.<init>(HmtpStream.java:78)
                           at com.caucho.cloud.heartbeat.HeartbeatActor.openStream(HeartbeatActor.java:444)
                           at com.caucho.cloud.heartbeat.HeartbeatActor.sendMessage(HeartbeatActor.java:397)
                           at com.caucho.cloud.heartbeat.HeartbeatActor.sendHeartbeatMessage(HeartbeatActor.java:379)
                           at com.caucho.cloud.heartbeat.HeartbeatActor.sendHeartbeatPod(HeartbeatActor.java:290)
                           at com.caucho.cloud.heartbeat.HeartbeatActor.sendHeartbeat(HeartbeatActor.java:237)
                           at com.caucho.cloud.heartbeat.HeartbeatActor.access$000(HeartbeatActor.java:64)
                           at com.caucho.cloud.heartbeat.HeartbeatActor$HeartBeatSender.run(HeartbeatActor.java:567)
                           at com.caucho.env.thread2.ResinThread2.runTasks(ResinThread2.java:173)
                           at com.caucho.env.thread2.ResinThread2.run(ResinThread2.java:118)
                       Caused by: com.caucho.vfs.ClientDisconnectException: SocketStream[null]:java.net.SocketException: Connection reset by peer: socket write error
                           at com.caucho.vfs.ClientDisconnectException.create(ClientDisconnectException.java:77)
                           at com.caucho.vfs.SocketStream.write(SocketStream.java:300)
                           at com.caucho.vfs.TcpStream.write(TcpStream.java:200)
                           at com.caucho.vfs.WriteStream.flush(WriteStream.java:399)
                           at com.caucho.network.balance.ClientSocket.switchToHmtp(ClientSocket.java:230)
                           ... 10 more
                       Caused by: java.net.SocketException: Connection reset by peer: socket write error
                           at java.net.SocketOutputStream.socketWrite0(Native Method)
                           at java.net.SocketOutputStream.socketWrite(Unknown Source)
                           at java.net.SocketOutputStream.write(Unknown Source)
                           at com.caucho.vfs.SocketStream.write(SocketStream.java:292)
                           ... 13 more
Additional Information
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
03-12-13 10:39 alex New Issue
05-02-13 11:55 ferg Assigned To  => ferg
05-02-13 11:55 ferg Status new => closed
05-02-13 11:55 ferg Resolution open => fixed
05-02-13 11:55 ferg Fixed in Version  => 4.0.37


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
27 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker