Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000534 [Quercus] minor always 12-21-05 08:46 12-02-05 15:18
Reporter bago View Status @0@  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0000534: strtr implementation for array doesn't work
Description from http://www.php.net/strtr [^]

Example 2. strtr() example with two arguments
<?php
$trans = array("hello" => "hi", "hi" => "hello");
echo strtr("hi all, I said hello", $trans);
?>

This will show:

hello all, I said hi

Instead it doesn't replace anything because it try to replace single chars and not whole strings.
Additional Information
Attached Files

- Relationships

- Notes
(0000561)
bago
12-22-05 16:19

This is fixed in 3.0.17
 
(0000610)
ferg
12-02-05 15:18

php/114a
 

- Issue History
Date Modified Username Field Change
12-21-05 08:46 bago New Issue
12-22-05 16:19 bago Note Added: 0000561
12-02-05 15:18 ferg Status new => closed
12-02-05 15:18 ferg Note Added: 0000610
12-02-05 15:18 ferg Resolution open => fixed
12-02-05 15:18 ferg Fixed in Version  => 3.0.18


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
31 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker