Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005108 [Resin] minor always 06-09-12 08:37 07-02-12 18:39
Reporter cowan View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 4.0.28
Summary 0005108: Compile flags for 32 vs 64 bit Apache
Description On Solaris 10, --with-apxs where Apache is 64-bit, make failed with:

ld: fatal: file .libs/mod_caucho.o: wrong ELF class: ELFCLASS32
ld: fatal: file processing errors. No output written to .libs/mod_caucho.so
collect2: ld returned 1 exit status
make[2]: *** [mod_caucho.la] Error 1

This is fixed when --enable-64-bit is included.

If possible, configure should default to 64-bit so the extra parameter is not required.
Additional Information
Attached Files

- Relationships

- Notes
(0005808)
cowan
06-09-12 08:41

Well actually now that I tried to start Apache after successful compile with --enable-64-bit, I get this:

-bash-3.2# ./bin/apachectl start
httpd: Syntax error on line 482 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/mod_caucho.so into server: ld.so.1: httpd: fatal: /usr/local/apache2/modules/mod_caucho.so: wrong ELF class: ELFCLASS64
 
(0005809)
cowan
06-09-12 08:46

After recompile with --disable-64bit Apache started up. So the issue is that we are attempting to use 64-bit for mod_caucho when Apache is 32-bit.
 

- Issue History
Date Modified Username Field Change
06-09-12 08:37 cowan New Issue
06-09-12 08:41 cowan Note Added: 0005808
06-09-12 08:46 cowan Note Added: 0005809
06-09-12 08:47 cowan Summary Detect 64-bit Apache => Compile flags for 32 vs 64 bit Apache
07-02-12 18:39 ferg Assigned To  => ferg
07-02-12 18:39 ferg Status new => resolved
07-02-12 18:39 ferg Resolution open => fixed
07-02-12 18:39 ferg Fixed in Version  => 4.0.30
07-02-12 18:39 ferg Status resolved => closed


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
31 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker