Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005071 [Resin] minor always 05-09-12 23:43 05-01-12 11:41
Reporter rickHigh View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0005071: Logger.exiting does not work with Resin for formmating parameters
Description             log.exiting(this.getClass().getName(), "updateBook", new Object[]{id, title, description, price, pubDate});

Not formating parameters correctly with default EL formatter from Resin.

[12-05-09 23:26:57.284]FINER BookRepositoryJDBCImpl updateBook msg= ENTRY 5 Peace and Peace 33 05/05/1999
[12-05-09 23:26:57.288]FINER BookRepositoryJDBCImpl updateBook msg= RETURN [Ljava.lang.Object;@24164d75

The return should read

_______

 BookRepositoryJDBCImpl updateBook msg= RETURN 5 Peace and Peace 33 05/05/1999

Not

BookRepositoryJDBCImpl updateBook msg= RETURN [Ljava.lang.Object;@24164d75

_________



    @Override
    public void updateBook(final String id, final String title, final String description,
            final String price, final String pubDate) {
        
        if (log.isLoggable(Level.FINER)) {
            log.entering(this.getClass().getName(), "updateBook", new Object[]{id, title, description, price, pubDate});
        }
                ...
        if (log.isLoggable(Level.FINER)) {
            log.exiting(this.getClass().getName(), "updateBook", new Object[]{id, title, description, price, pubDate});
        }

    }
Additional Information
Attached Files

- Relationships

- Notes
(0005790)
ferg
05-01-12 11:41

env/023i

Although, the example is incorrect because exiting is supposed to use the return value, not the parameter value.
 

- Issue History
Date Modified Username Field Change
05-09-12 23:43 rickHigh New Issue
05-01-12 11:41 ferg Note Added: 0005790
05-01-12 11:41 ferg Assigned To  => ferg
05-01-12 11:41 ferg Status new => closed
05-01-12 11:41 ferg Resolution open => fixed
05-01-12 11:41 ferg Fixed in Version  => 4.0.28


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker