Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005056 [Resin] minor always 04-02-12 09:48 05-06-12 11:51
Reporter cowan View Status public  
Assigned To cowan
Priority high Resolution fixed  
Status closed   Product Version 3.1.12
Summary 0005056: Handle multiple domain names for cookie-domain
Description When a webapp is used by multiple domains, cookie-domain can not be set in configuration because it accepts only 1 domain. When domain name switches hosts, such as from "www" to "secure" the cookie must be maintained. cookie-domain cannot be blank, because Resin defauls to use the full host name, such as "www.foo.com", which is then lost at the switch to "secure.foo.com".
Additional Information
Attached Files

- Relationships

- Notes
(0005750)
cowan
04-02-12 12:55

Handled in Resin 4 with cookie-domain-regexp.

Backport 3865.

http://bugs.caucho.com/view.php?id=3865 [^]
 
(0005755)
cowan
05-06-12 11:51

Backported to 3.1

server/010w
server/010x
 

- Issue History
Date Modified Username Field Change
04-02-12 09:48 cowan New Issue
04-02-12 12:55 cowan Note Added: 0005750
05-02-12 08:56 cowan Status new => assigned
05-02-12 08:56 cowan Assigned To  => cowan
05-06-12 11:51 cowan Status assigned => closed
05-06-12 11:51 cowan Note Added: 0005755
05-06-12 11:51 cowan Resolution open => fixed
05-06-12 11:51 cowan Fixed in Version  => 3.1.13


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
30 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker