Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004854 [Resin] major sometimes 11-11-11 00:51 11-02-11 13:06
Reporter georgbuschbeck View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 4.0.23
Summary 0004854: ERROR: IllegalStateExceptionblock at 0x1b732000 is invalid for file /<path-to-resin-home>/resindata/<serverid>/distcache/data.db
Description ERROR: IllegalStateExceptionblock at 0x1b732000 is invalid for file /<path-to-resin-home>/resindata/<serverid>/distcache/data.db (length 0xe000000)

java.lang.IllegalStateException: block at 0x1b732000 is invalid for file /<path-to-resin-home>/resindata/<serverid>/distcache/data.db (length 0xe000000)
    at com.caucho.db.block.BlockReadWrite.readBlockImpl(BlockReadWrite.java:192)
    at com.caucho.db.block.BlockReadWrite.readBlock(BlockReadWrite.java:169)
    at com.caucho.db.block.Block.read(Block.java:256)
    at com.caucho.db.block.BlockStore.readBlock(BlockStore.java:538)
    at com.caucho.db.block.BlockStore.readBlockNoLock(BlockStore.java:1014)
    at com.caucho.db.blob.Inode.readToOutput(Inode.java:419)
    at com.caucho.db.blob.Inode.writeToStream(Inode.java:265)
    at com.caucho.db.blob.BlobInputStream.readToOutput(BlobInputStream.java:123)
    at com.caucho.server.distcache.AbstractCacheManager.loadData(AbstractCacheManager.java:1261)
    at com.caucho.server.distcache.AbstractCacheManager.readData(AbstractCacheManager.java:1224)
    at com.caucho.server.distcache.AbstractCacheManager.getStream(AbstractCacheManager.java:244)
    at com.caucho.distcache.cluster.ProCacheEntry.getStream(ProCacheEntry.java:107)
    at com.caucho.distcache.AbstractCache.get(AbstractCache.java:535)
    at com.caucho.server.session.SessionImpl.load(SessionImpl.java:670)
    at com.caucho.server.session.SessionManager.createSession(SessionManager.java:1361)
    at com.caucho.server.http.AbstractCauchoRequest.createSession(AbstractCauchoRequest.java:255)
    at com.caucho.server.http.AbstractCauchoRequest.getSession(AbstractCauchoRequest.java:198)
    at org.apache.wicket.protocol.http.AbstractHttpSessionStore.getSessionId(AbstractHttpSessionStore.java:181)
    at org.apache.wicket.protocol.http.WicketFilter.doGet(WicketFilter.java:414)
    at org.apache.wicket.protocol.http.WicketFilter.doFilter(WicketFilter.java:301)
    at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:89)
    at org.codesmell.jpsak.servlet.EntityManagerFilter.doFilter(EntityManagerFilter.java:40)
    at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:89)
    at com.softculture.services.errornotification.servlet.ENFilter.doFilter(ENFilter.java:47)
    at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:89)
    at com.caucho.server.webapp.WebAppFilterChain.doFilter(WebAppFilterChain.java:156)
    at com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:289)
    at com.caucho.server.hmux.HmuxRequest.handleInvocation(HmuxRequest.java:470)
    at com.caucho.server.hmux.HmuxRequest.handleRequestImpl(HmuxRequest.java:371)
    at com.caucho.server.hmux.HmuxRequest.handleRequest(HmuxRequest.java:337)
    at com.caucho.network.listen.TcpSocketLink.dispatchRequest(TcpSocketLink.java:1215)
    at com.caucho.network.listen.TcpSocketLink.handleRequest(TcpSocketLink.java:1171)
    at com.caucho.network.listen.TcpSocketLink.handleRequestsImpl(TcpSocketLink.java:1155)
    at com.caucho.network.listen.TcpSocketLink.handleRequests(TcpSocketLink.java:1078)
    at com.caucho.network.listen.TcpSocketLink.handleAcceptTask(TcpSocketLink.java:907)
    at com.caucho.network.listen.AcceptTask.doTask(AcceptTask.java:74)
    at com.caucho.network.listen.TcpSocketLink.handleRequests(TcpSocketLink.java:1125)
    at com.caucho.network.listen.TcpSocketLink.handleKeepaliveTask(TcpSocketLink.java:931)
    at com.caucho.network.listen.KeepaliveRequestTask.doTask(KeepaliveRequestTask.java:69)
    at com.caucho.network.listen.ConnectionTask.runThread(ConnectionTask.java:97)
    at com.caucho.network.listen.ConnectionTask.run(ConnectionTask.java:80)
    at com.caucho.network.listen.KeepaliveRequestTask.run(KeepaliveRequestTask.java:57)
    at com.caucho.env.thread.ResinThread.runTasks(ResinThread.java:164)
    at com.caucho.env.thread.ResinThread.run(ResinThread.java:130)
Additional Information Running on Debian Squeeze (AMD64), sun-java6-jdk, (1.6.0_26), kvm-virutalized

perhaps an regression, as i found this mail here:
http://maillist.caucho.com/pipermail/resin-interest/2008-October/002989.html [^]
Attached Files

- Relationships

- Notes
(0005614)
georgbuschbeck
11-11-11 00:53

happens from time to time, then "heals" it self till it starts again
 
(0005644)
ferg
11-02-11 13:06

Note, this isn't a regression, but it's in a similar part of code.

Because this is a timing-related bug, it's not 100% certain that the fix exactly fixes the case you're seeing. If after 4.0.25, you see anything similar, please file a new bug report on the new behavior.
 

- Issue History
Date Modified Username Field Change
11-11-11 00:51 georgbuschbeck New Issue
11-11-11 00:53 georgbuschbeck Note Added: 0005614
11-02-11 13:06 ferg Note Added: 0005644
11-02-11 13:06 ferg Assigned To  => ferg
11-02-11 13:06 ferg Status new => closed
11-02-11 13:06 ferg Resolution open => fixed
11-02-11 13:06 ferg Fixed in Version  => 4.0.25


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
31 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker