Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004840 [Quercus] major always 11-05-11 12:31 11-05-11 12:31
Reporter diyism View Status public  
Assigned To
Priority normal Resolution open  
Status new   Product Version 4.0.14
Summary 0004840: com.caucho.quercus.QuercusException: java.lang.reflect.Method.invoke: argument type mismatch
Description Always show error:
com.caucho.quercus.QuercusException: java.lang.reflect.Method.invoke: argument type mismatch

The java code:
public class GaeFileObject extends AbstractFileObject
  implements Serializable
  private boolean isCombinedLocal;

  public void setCombinedLocal(boolean b) {
    this.isCombinedLocal = b;

The php code:
import com.newatlanta.commons.vfs.provider.gae.GaeVFS;
import java.lang.Long;
import java.lang.Boolean;
define('VFSM', GaeVFS::getManager());
$file=VFSM->resolveFile('gae://gaevfs/tmp1'); [^]
$file->getClass()->getDeclaredMethod('setCombinedLocal', array(Boolean::TYPE))->invoke($file, true);

The last line "invoke" trigger the "argument type mismatch" error.
and i tried:
$file->getClass()->getDeclaredMethod('setCombinedLocal', array(Boolean::TYPE))->invoke($file, new Boolean('true'));
And the error is still the same.

I can't figure out why. It's maybe a bug of quercus.
Additional Information
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
11-05-11 12:31 diyism New Issue

Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
26 total queries executed.
24 unique queries executed.
Powered by Mantis Bugtracker