Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004781 [Resin] minor always 09-02-11 12:26 10-07-11 14:58
Reporter cowan View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 4.0.23
Summary 0004781: ThreaDump on shutdown from AbstractThreadLauncher.updateThrottle
Description Thread dump in from AbstractThreadLauncher.updateThrottle, see below.

I can trigger this using Resin pro without a license and without native libs if I add admin-users.xml and then hit a page. Or maybe it has to do with how soon after restart I modify. Definitely a timing thing.

-Paul

Please file this as a bug.

The thread dump is supposed to catch a case where the threads are spiking uncontrollably. I don't know if it's catching an actual issue or if it's a problem in the reporting.

-- Scott

[11-09-30 14:48:34.645] {http://*:8080-1} [^] /Users/paul/resin-pro-4.0.23/conf/admin-users.xml length is modified (0 -> 353)
[11-09-30 14:48:34.645] {http://*:8080-1} [^] Host[production/host/default] stopping
[11-09-30 14:48:34.663] {http://*:8080-1} [^] WebApp[production/webapp/default/resin-doc] stopping
[11-09-30 14:48:34.706] {http://*:8080-1} [^] WebApp[production/webapp/default/resin-admin] stopping
[11-09-30 14:48:34.715] {http://*:8080-1} [^] WebApp[production/webapp/default/ROOT] stopping
WarningService: Server restarting due to configuration change
[11-09-30 14:48:34.848] {http://*:8080-1} [^] WarningService: Server restarting due to configuration change
[11-09-30 14:48:34.985] {resin-shutdown} Server[id=default,cluster=app-tier] stopping
[11-09-30 14:48:35.087] {ThreadLauncher[ThreadPool[system]]-1} ThreadLauncher[ThreadPool[system]] 100 threads created in 1000ms sleep=10ms
[11-09-30 14:48:35.114] {ThreadLauncher[ThreadPool[system]]-1} Thread Dump generated Fri Sep 30 14:48:35 EDT 2011
                                                               "Signal Dispatcher" id=6 RUNNABLE
                                                               
                                                               "ThreadLauncher[ThreadPool[system]]-1" id=11 RUNNABLE
                                                                 at sun.management.ThreadImpl.getThreadInfo1 (ThreadImpl.java) (native)
                                                                 at sun.management.ThreadImpl.getThreadInfo (ThreadImpl.java:156)
                                                                 at com.caucho.util.ThreadDump.getThreadDump (ThreadDump.java:121)
                                                                 at com.caucho.util.ThreadDump.getThreadDump (ThreadDump.java:99)
                                                                 at com.caucho.util.ThreadDump.dumpThreads (ThreadDump.java:91)
                                                                 at com.caucho.env.thread.AbstractThreadLauncher.updateThrottle (AbstractThreadLauncher.java:514)
                                                                 at com.caucho.env.thread.AbstractThreadLauncher.startConnection (AbstractThreadLauncher.java:469)
                                                                 at com.caucho.env.thread.AbstractThreadLauncher.runTask (AbstractThreadLauncher.java:550)
                                                                 at com.caucho.env.thread.AbstractTaskWorker.run (AbstractTaskWorker.java:172)
                                                                 at java.lang.Thread.run (Thread.java:680)
                                                               
Additional Information
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
09-02-11 12:26 cowan New Issue
10-07-11 14:58 ferg Assigned To  => ferg
10-07-11 14:58 ferg Status new => closed
10-07-11 14:58 ferg Resolution open => fixed
10-07-11 14:58 ferg Fixed in Version  => 4.0.24


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
27 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker