Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004683 [Resin] minor always 07-25-11 12:12 07-28-11 16:47
Reporter ferg View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 4.0.20
Summary 0004683: ThreadPool full
Description (rep by Amir Langer)

java.lang.IllegalStateException: Thread pool full
    at com.caucho.env.thread.ThreadPool.scheduleImpl(
    at com.caucho.env.thread.ThreadPool.start(
    at com.caucho.env.thread.AbstractThreadLauncher.startConnection(
    at com.caucho.env.thread.AbstractThreadLauncher.runTask(
    at com.caucho.env.thread.ResinThread.runTasks(

This exception is then repeated continuously and resin then is basically just busy generating exceptions.

It is happening in our continuous integration env. and the usage in both cases is identical.

We tried various different thead pool settings

Our current thread pool settings are:


and we tried to play with the numbers a bit but none of the changes seemed to make a difference to the difference in behaviour.

For some reason 4.0.20 uses all the threads and blows up while 4.0.19-snapshot-2 will happily work even with a thread-max of 512.
Additional Information "http://*:9090-66968" [^] daemon prio=10 tid=0x0000000053c3d000 nid=0x6add runnable [0x0000000043285000]
   java.lang.Thread.State: RUNNABLE
    at com.caucho.vfs.JniSocketImpl.readNative(Native Method)
    - locked <0x0000000720d070b0> (a java.lang.Object)
    at com.caucho.vfs.JniStream.readTimeout(
    at com.caucho.vfs.ReadStream.fillWithTimeout(
    at com.caucho.env.thread.ResinThread.runTasks(
Attached Files

- Relationships

- Notes
07-28-11 16:47


- Issue History
Date Modified Username Field Change
07-25-11 12:12 ferg New Issue
07-28-11 16:47 ferg Note Added: 0005408
07-28-11 16:47 ferg Assigned To  => ferg
07-28-11 16:47 ferg Status new => closed
07-28-11 16:47 ferg Resolution open => fixed
07-28-11 16:47 ferg Fixed in Version  => 4.0.21
07-28-11 16:47 ferg Additional Information Updated
09-16-11 02:50 apleshi Issue Monitored: apleshi

Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
31 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker