Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004529 [Resin] minor always 04-01-11 10:04 05-17-11 10:01
Reporter ferg View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0004529: mod_caucho threading issue
Description (rep by remkodev)

See http://forum.caucho.com/showthread.php?t=27741 [^]


The thread's last resin function is cse_free_lock

cse_free_lock(config_t *config, void *vlock)
{
apr_thread_mutex_destroy(vlock);
}

After some research, it appears that apr_thread_mutex_destroy(vlock); is not thread safe.

(https://www.securecoding.cert.org/co...read%27s+mutex) [^]

We figured that because our webservers uses multiple resin servers (around 6) in each vhost/apache instance these will cause the race condition over the thread_mutex_destroy method.

Today I altered the configuration of the most busy app ( Note: 0000090% off the hits) to be proxied to a seprate webserver with only 1 resin host configured. This setup did not cause a single hanging process for over 4 hours.

Additional Information
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
04-01-11 10:04 ferg New Issue
05-17-11 10:01 ferg Assigned To  => ferg
05-17-11 10:01 ferg Status new => closed
05-17-11 10:01 ferg Resolution open => fixed
05-17-11 10:01 ferg Fixed in Version  => 4.0.19


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
32 total queries executed.
29 unique queries executed.
Powered by Mantis Bugtracker