Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004444 [Resin] minor always 03-22-11 11:11 04-05-11 15:21
Reporter ferg View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 4.0.16
Summary 0004444: web-app in resin.xml combining with ROOT.war
Description (rep by Keith Fetterman)

I am experiencing a problem in resin 4.0.16 where resin is not expanding
the ROOT.war file if I explicitly define the root webapp in resin.xml
file. In resin.xml, I have the tag "<web-app id="/"
root-directory="webapps/ROOT"/>" defined under my"<host>" tag. I also
have the tag "<web-app-deploy path="webapps" versioning="true"/>"
defined under my "<host-default>" tag.

When I update the ROOT.war file in my "webapps" directory, the war file
is not being expanded into the webapps/ROOT directory. I have tried
both shutting down resin, updating the ROOT.war file and then starting
resin, and I've tried updating ROOT.war while resin is running.

If I remove the tag "<web-app id="/" root-directory="webapps/ROOT"/>"
from the resin.xml file, then ROOT.war expansion occurs.

Do I need to add an attribute to the<web-app id="/"
root-directory="webapps/ROOT"/> tag to get the war file to expand?
Additional Information
Attached Files

- Relationships

- Notes
04-04-11 19:07
edited on: 04-05-11 13:47


versioning="true" is needed to duplicate the problem.


- Issue History
Date Modified Username Field Change
03-22-11 11:11 ferg New Issue
04-04-11 19:07 ferg Note Added: 0005150
04-05-11 13:47 ferg Note Edited: 0005150
04-05-11 15:21 ferg Assigned To  => ferg
04-05-11 15:21 ferg Status new => closed
04-05-11 15:21 ferg Resolution open => fixed
04-05-11 15:21 ferg version  => 4.0.16
04-05-11 15:21 ferg Fixed in Version  => 4.0.17

Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
30 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker