Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004352 [Resin] minor always 01-21-11 06:10 01-21-11 12:38
Reporter mros2stf View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 4.0.14
Summary 0004352: ssl doesn't actually make automatically
Description When installing 4.0.14 on SLES 10.3 with the following options, the libresinssl.so does not automatically get created. I have to manually issue the make, and manually copy the file to the libexec64 directory after the "make install". It then works fine, but why doesn't it do it?

Additional Information config script:
./configure --prefix=/usr/local/resin --with-resin-root=/var/www --with-resin-log=/var/log/resin --with-resin-conf=/etc/resin --enable-64bit --enable-jni --enable-ssl CFLAGS=-fPIC

Resin Configuration summary:

  RESIN_HOME: /usr/local/resin
      root: /var/www
      conf: /etc/resin
      log : /var/log/resin
      init: /etc/init.d/resin
  JAVA_HOME: /usr/lib64/jvm/java

    + 64-bit JNI in -I/usr/lib64/jvm/java/include
    + JNI CFLAGS: -fPIC -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI
    + epoll() for keepalives
    + OpenSSL 0.9.8a 11 Oct 2005
        OpenSSL include: /usr/include
        OpenSSL lib: /usr/lib64
        OpenSSL libraries: -lssl -lcrypto

The results below, and you can see where the make of the ssl is ok, but I had to manually do it.

adczlnxhmiqa1:/var/opt/resin-pro-4.0.14 # make
Makefile:283: warning: overriding commands for target `modules/c/src/Makefile'
Makefile:273: warning: ignoring old commands for target `modules/c/src/Makefile'
(cd modules/c/src; make)
make[1]: Entering directory `/var/opt/resin-pro-4.0.14/modules/c/src'
for dir in common resin_os ; do (cd $dir; make); done
make[2]: Entering directory `/var/opt/resin-pro-4.0.14/modules/c/src/common'
gcc -c -I/usr/include -fPIC -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI stream.c
stream.c: In function ‚select_host‚:
stream.c:1394: warning: cast from pointer to integer of different size
gcc -c -I/usr/include -fPIC -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI config.c
gcc -c -I/usr/include -fPIC -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI memory.c
/var/opt/resin-pro-4.0.14/libtool --silent --mode=compile gcc -o stream.lo -c -I/usr/include -fPIC -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI stream.c
stream.c: In function ‚select_host‚:
stream.c:1394: warning: cast from pointer to integer of different size
/var/opt/resin-pro-4.0.14/libtool --silent --mode=compile gcc -o config.lo -c -I/usr/include -fPIC -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI config.c
/var/opt/resin-pro-4.0.14/libtool --silent --mode=compile gcc -o memory.lo -c -I/usr/include -fPIC -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI memory.c
make[2]: Leaving directory `/var/opt/resin-pro-4.0.14/modules/c/src/common'
make[2]: Entering directory `/var/opt/resin-pro-4.0.14/modules/c/src/resin_os'
gcc -fPIC -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI -m64 -fPIC -DRESIN_HOME=\"/usr/local/resin\" -I/usr/include -I/usr/lib64/jvm/java/include -I../common -DCPU=\"s390x\" -DOS= -c -o boot.o boot.c
gcc -fPIC -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI -m64 -fPIC -DRESIN_HOME=\"/usr/local/resin\" -I/usr/include -I/usr/lib64/jvm/java/include -I../common -DCPU=\"s390x\" -DOS= -c -o java.o java.c
gcc -fPIC -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI -m64 -fPIC -DRESIN_HOME=\"/usr/local/resin\" -I/usr/include -I/usr/lib64/jvm/java/include -I../common -DCPU=\"s390x\" -DOS= -c -o jni_os.o jni_os.c
gcc -fPIC -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI -m64 -fPIC -DRESIN_HOME=\"/usr/local/resin\" -I/usr/include -I/usr/lib64/jvm/java/include -I../common -DCPU=\"s390x\" -DOS= -c -o jni_jvmti.o jni_jvmti.c
gcc -fPIC -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI -m64 -fPIC -DRESIN_HOME=\"/usr/local/resin\" -I/usr/include -I/usr/lib64/jvm/java/include -I../common -DCPU=\"s390x\" -DOS= -c -o jni_socket.o jni_socket.c
gcc -fPIC -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI -m64 -fPIC -DRESIN_HOME=\"/usr/local/resin\" -I/usr/include -I/usr/lib64/jvm/java/include -I../common -DCPU=\"s390x\" -DOS= -c -o memory.o memory.c
gcc -fPIC -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI -m64 -fPIC -DRESIN_HOME=\"/usr/local/resin\" -I/usr/include -I/usr/lib64/jvm/java/include -I../common -DCPU=\"s390x\" -DOS= -c -o std.o std.c
gcc -shared -fPIC -L/usr/lib64 -o libresin_os.so boot.o java.o jni_os.o jni_jvmti.o jni_socket.o memory.o std.o -lpthread -lc
make[2]: Leaving directory `/var/opt/resin-pro-4.0.14/modules/c/src/resin_os'
make[1]: Leaving directory `/var/opt/resin-pro-4.0.14/modules/c/src'
if test -r ./modules/c/src/Makefile; then \
  cd ./modules/c/src; make; \
fi
make[1]: Entering directory `/var/opt/resin-pro-4.0.14/modules/c/src'
for dir in common resin_os ; do (cd $dir; make); done
make[2]: Entering directory `/var/opt/resin-pro-4.0.14/modules/c/src/common'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/var/opt/resin-pro-4.0.14/modules/c/src/common'
make[2]: Entering directory `/var/opt/resin-pro-4.0.14/modules/c/src/resin_os'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/var/opt/resin-pro-4.0.14/modules/c/src/resin_os'
make[1]: Leaving directory `/var/opt/resin-pro-4.0.14/modules/c/src'
adczlnxhmiqa1:/var/opt/resin-pro-4.0.14 # cd modules/c/src/resinssl
adczlnxhmiqa1:/var/opt/resin-pro-4.0.14/modules/c/src/resinssl # ls
Makefile Makefile.in resinssl.def resinssl.vcproj ssl.c ssl_stub.c
adczlnxhmiqa1:/var/opt/resin-pro-4.0.14/modules/c/src/resinssl # make
gcc -fPIC -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI -DRESIN_HOME=\"/usr/local/resin\" -I/usr/include -I/usr/lib64/jvm/java/include -I../common -I../resin -DCPU=\"s390x\" -DOS= -m64 -fPIC -fpic -DSSL_ENGINE -c -o ssl.o ssl.c
gcc -shared -fPIC -L/usr/lib64 -o libresinssl.so ssl.o ../resin_os/memory.o ../resin_os/std.o ../resin_os/java.o -lpthread -lc -lssl -lcrypto
adczlnxhmiqa1:/var/opt/resin-pro-4.0.14/modules/c/src/resinssl # ls
Makefile libresinssl.so resinssl.vcproj ssl.o
Makefile.in resinssl.def ssl.c ssl_stub.c



Attached Files

- Relationships

- Notes
(0004986)
ferg
01-21-11 12:38

Looks like a ./configure issue. For some reason, it thinks you're in a Resin development configuration (with ../pro/modules/c/src/resin/resin.h) existing.

I've changed the ./configure to look for the deployment in preference.
 

- Issue History
Date Modified Username Field Change
01-21-11 06:10 mros2stf New Issue
01-21-11 12:38 ferg Note Added: 0004986
01-21-11 12:38 ferg Assigned To  => ferg
01-21-11 12:38 ferg Status new => closed
01-21-11 12:38 ferg Resolution open => fixed
01-21-11 12:38 ferg Fixed in Version  => 4.0.15


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker